Bug 587600 - [abrt] crash in vcl::DisplayConnection::dispatchEvent
Summary: [abrt] crash in vcl::DisplayConnection::dispatchEvent
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f6d3e9ebdbe7802aa4c506f0407...
Keywords:
: 558122 588140 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-30 11:01 UTC by Mustafa Hasan TUNCER
Modified: 2010-07-28 07:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 07:46:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (54.37 KB, text/plain)
2010-04-30 11:01 UTC, Mustafa Hasan TUNCER
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 111106 None None None Never
OpenOffice.org 113259 None None None Never

Description Mustafa Hasan TUNCER 2010-04-30 11:01:36 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/soffice.bin -quickstart -nologo -nodefault
component: openoffice.org
executable: /usr/lib/openoffice.org3/program/soffice.bin
global_uuid: f6d3e9ebdbe7802aa4c506f0407d278428b6f8e2
kernel: 2.6.32.11-99.fc12.i686.PAE
package: openoffice.org-brand-1:3.1.1-19.28.fc12
rating: 4
reason: Process /usr/lib/openoffice.org3/program/soffice.bin was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

Comment 1 Mustafa Hasan TUNCER 2010-04-30 11:01:39 UTC
Created attachment 410371 [details]
File: backtrace

Comment 2 Caolan McNamara 2010-04-30 11:08:03 UTC
This has the look of a crash during processing of an XEvent during shutdown.

Comment 3 Caolan McNamara 2010-05-04 08:01:27 UTC
*** Bug 558122 has been marked as a duplicate of this bug. ***

Comment 4 Caolan McNamara 2010-05-04 08:04:07 UTC
*** Bug 588140 has been marked as a duplicate of this bug. ***

Comment 5 Caolan McNamara 2010-05-04 08:05:48 UTC
These are crashes that are happening because of processing events after shutdown. What I don't know is how and when this happens, one possibility is logging out with OOo running (e.g. the quickstarter in the taskbar) and having the session save stuff kick in.

Comment 6 Caolan McNamara 2010-05-18 12:00:52 UTC
Anyone able to get this to happen reproducibly ? Window managers, info as to whether they saw it on KDE or GNOME, etc. is welcome.

Comment 7 Caolan McNamara 2010-07-01 19:29:39 UTC
caolanm->caolanm: ToDo, configure quickstarter on, add valgrind to soffice wrapper script and output to some location, log-in and log-out and see if it gives any hints.

Comment 8 Caolan McNamara 2010-07-19 14:50:30 UTC
bah, gtk_init is setting an XSetIOErrorHandler after we do, so we revert to the exit one, not _exit

Comment 9 Caolan McNamara 2010-07-19 19:46:26 UTC
A bit tricky, various things are sort of wrong. Not the world most serious set of bugs as they're on shutdown/log-out and around XIOErrors and XErrors. 

Hopefully the cluster of problems is sorted out in 3.3 with the addition of the extra XIOError handler fix


Note You need to log in before you can comment on or make changes to this bug.