Bug 587637 - udevd[430]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/90-alsa-tools-firmware.rules
Summary: udevd[430]: BUS= will be removed in a future udev version, please use SUBSYST...
Status: CLOSED DUPLICATE of bug 583494
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-tools   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-30 12:59 UTC by James Laska
Modified: 2013-09-02 06:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 17:10:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/boot.log (7.66 KB, application/octet-stream)
2010-04-30 12:59 UTC, James Laska
no flags Details

Description James Laska 2010-04-30 12:59:01 UTC
Created attachment 410398 [details]
/var/log/boot.log

Description of problem:

Booting Fedora-13-Final-TC1-x86_64 live image displays many udev deprecation messages on boot regarding alsa-tools-firmware.rules file.  For example..

udevd[430]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/90-alsa-tools-firmware.rules

Version-Release number of selected component (if applicable):
* alsa-tools-firmware-1.0.22-1.fc13.x86_64

How reproducible:
* 100%

Steps to Reproduce:
1. Boot http://serverbeach1.fedoraproject.org/pub/alt/stage/13.TC1/Fedora-13-x86_64-Live/Fedora-13-x86_64-Live.iso as a guest on a Fedora 13 KVM host
  
Actual results:

See attached boot.log for full details.

		Welcome to Fedora 
		Press 'I' to enter interactive startup.
Starting udev: udevd[430]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/90-alsa-tools-firmware.rules:2

udevd[430]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/90-alsa-tools-firmware.rules:3

udevd[430]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/90-alsa-tools-firmware.rules:6

udevd[430]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/90-alsa-tools-firmware.rules:7

Expected results:

No deprecation messages on boot.

Additional info:

Comment 1 James Laska 2010-04-30 17:10:11 UTC

*** This bug has been marked as a duplicate of bug 583494 ***


Note You need to log in before you can comment on or make changes to this bug.