Bug 587692 - Expand image descriptions in images/README
Expand image descriptions in images/README
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Dennis Gregorovic
Release Test Team
:
Depends On: 584595
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-30 11:26 EDT by Dennis Gregorovic
Modified: 2011-05-19 08:55 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 584595
Environment:
Last Closed: 2011-05-19 08:55:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 RHEL Product and Program Management 2010-04-30 11:47:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Dennis Gregorovic 2010-06-10 10:21:51 EDT
Changes checked into distill
Comment 3 Alexander Todorov 2010-06-29 06:24:51 EDT
# pwd
/mnt/redhat/rel-eng/RHEL6.0-20100622.1/6

# find -name "README" | sort
./Client/i386/os/images/README
./Client/x86_64/os/images/README
./ComputeNode/x86_64/os/images/README
./Server/i386/os/images/README
./Server/ppc64/os/images/README
./Server/s390x/os/images/README
./Server/x86_64/os/images/README
./WebServer/x86_64/os/images/README
./Workstation/i386/os/images/README
./Workstation/x86_64/os/images/README



# cat ./Workstation/x86_64/os/images/README
This directory contains image files that can be used to create media
capable of starting the Red Hat Enterprise Linux 6 installation process.

The boot.iso file is an ISO 9660 image of a bootable CD-ROM.  It is useful
in cases where the CD-ROM installation method is not desired, but the
CD-ROM's boot speed would be an advantage.

To use this image file, burn the file onto CD-R (or CD-RW) media as you
normally would.

Dennis,
the README file is present but it describes only boot.iso and none of the other files. Do you want me to open another bug for this or move back to ASSIGNED?
Comment 4 Dennis Gregorovic 2010-06-29 08:32:55 EDT
That README test is as expected.  It's the same as the original README text from before.  If you open up a DVD, you'll notice that the text is different there.

-----------
# mount -o loop RHEL6.0-20100629.n.0-Server-i386-DVD1.iso /mnt/loop
# cat /mnt/loop/images/README 
This directory contains image files used during the Red Hat Enterprise
Linux 6 installation process.

The boot.iso file that is sometimes found in the images directory has
been removed for space reasons.  It is available as a separate download
from RHN.  boot.iso is an ISO 9660 image of a bootable CD-ROM.  It is useful
in cases where the CD-ROM installation method is not desired, but the
CD-ROM's boot speed would be an advantage.

To use this image file, burn the file onto CD-R (or CD-RW) media as you
-----------

This is the version of README that customers will see and where we wanted to point out that boot.iso is now a separate download.  How does the wording look to you?
Comment 5 Alexander Todorov 2010-06-29 08:41:11 EDT
This looks OK but I was asking if there is going to be description of other files like:

./efiboot.img
./efidisk.img
./install.img
./pxeboot/initrd.img
./pxeboot/vmlinuz
./product.img
Comment 6 Dennis Gregorovic 2010-06-29 08:47:24 EDT
David, could someone from the anaconda team help with some brief descriptions of the above files?
Comment 7 Alexander Todorov 2010-07-07 12:09:25 EDT
Moving back to ASSIGNED because there hasn't been an update to this bug for a week and the latest compose still describes only boot.iso in the README files.
Comment 10 David Cantrell 2011-02-08 14:09:56 EST
(In reply to comment #5)
> This looks OK but I was asking if there is going to be description of other
> files like:
> 
> ./efiboot.img

CD/DVD boot image for EFI systems

> ./efidisk.img

USB boot image for EFI systems (can be dd'ed to a USB flash drive)

> ./install.img

Installation image, loaded when you start the installation from a supported boot method.

> ./pxeboot/initrd.img

Initial ramdisk file for PXE-capable systems (i386 and x86_64)

> ./pxeboot/vmlinuz

Kernel image for PXE-capable systems (i386 and x86_64)

> ./product.img

RHEL product description information used in the installer
Comment 11 Dennis Gregorovic 2011-02-08 15:22:12 EST
new README on DVD:

This directory contains image files used during the Red Hat Enterprise
Linux 6 installation process.  These image files include the following:

efiboot.img: CD/DVD boot image for EFI systems
efidisk.img: USB boot image for EFI systems (can be dd'ed to a USB
             flash drive)
install.img: Installation image, loaded when you start the installation
             from a supported boot method.
pxeboot/initrd.img: Initial ramdisk file for PXE-capable systems (i386
                    and x86_64)
pxeboot/vmlinuz: Kernel image for PXE-capable systems (i386 and x86_64)
product.img: RHEL product description information used in the installer

The boot.iso file that is sometimes found in the images directory has
been removed for space reasons.  It is available as a separate download
from RHN.  boot.iso is an ISO 9660 image of a bootable CD-ROM.  It is useful
in cases where the CD-ROM installation method is not desired, but the
CD-ROM's boot speed would be an advantage.

To use this image file, burn the file onto CD-R (or CD-RW) media as you
normally would.

It is also possible to use boot.iso to create bootable USB media.  To do
so, use the dd utility to copy the boot.iso content to the USB media.
Detailed instructions can be found in the Red Hat Enterprise Linux 6
Installation Guide.

new README is os/images directory:

This directory contains image files used during the Red Hat Enterprise
Linux 6 installation process.  These image files include the following:

efiboot.img: CD/DVD boot image for EFI systems
efidisk.img: USB boot image for EFI systems (can be dd'ed to a USB
             flash drive)
install.img: Installation image, loaded when you start the installation
             from a supported boot method.
pxeboot/initrd.img: Initial ramdisk file for PXE-capable systems (i386
                    and x86_64)
pxeboot/vmlinuz: Kernel image for PXE-capable systems (i386 and x86_64)
product.img: RHEL product description information used in the installer

This directory also contains an image file that can be used to create media
capable of starting the Red Hat Enterprise Linux 6 installation process.
The boot.iso file is an ISO 9660 image of a bootable CD-ROM.  It is useful
in cases where the CD-ROM installation method is not desired, but the
CD-ROM's boot speed would be an advantage.

To use this image file, burn the file onto CD-R (or CD-RW) media as you
normally would.

It is also possible to use boot.iso to create bootable USB media.  To do
so, use the dd utility to copy the boot.iso content to the USB media.
Detailed instructions can be found in the Red Hat Enterprise Linux 6
Installation Guide.
Comment 13 Alexander Todorov 2011-02-16 03:14:01 EST
README file in the compose:

# cat ./Workstation/x86_64/os/images/README
This directory contains image files used during the Red Hat Enterprise
Linux 6 installation process.  These image files include the following:

efiboot.img: CD/DVD boot image for EFI systems
efidisk.img: USB boot image for EFI systems (can be dd'ed to a USB
             flash drive)
install.img: Installation image, loaded when you start the installation
             from a supported boot method.
pxeboot/initrd.img: Initial ramdisk file for PXE-capable systems (i386
                    and x86_64)
pxeboot/vmlinuz: Kernel image for PXE-capable systems (i386 and x86_64)
product.img: RHEL product description information used in the installer

This directory also contains an image file that can be used to create media
capable of starting the Red Hat Enterprise Linux 6 installation process.
The boot.iso file is an ISO 9660 image of a bootable CD-ROM.  It is useful
in cases where the CD-ROM installation method is not desired, but the
CD-ROM's boot speed would be an advantage.

To use this image file, burn the file onto CD-R (or CD-RW) media as you
normally would.

It is also possible to use boot.iso to create bootable USB media.  To do
so, use the dd utility to copy the boot.iso content to the USB media.
Detailed instructions can be found in the Red Hat Enterprise Linux 6
Installation Guide.




README file on DVD:
# cat /var/www/html/rhel/images/README 
This directory contains image files used during the Red Hat Enterprise
Linux 6 installation process.  These image files include the following:

efiboot.img: CD/DVD boot image for EFI systems
efidisk.img: USB boot image for EFI systems (can be dd'ed to a USB
             flash drive)
install.img: Installation image, loaded when you start the installation
             from a supported boot method.
pxeboot/initrd.img: Initial ramdisk file for PXE-capable systems (i386
                    and x86_64)
pxeboot/vmlinuz: Kernel image for PXE-capable systems (i386 and x86_64)
product.img: RHEL product description information used in the installer

The boot.iso file that is sometimes found in the images directory has
been removed for space reasons.  It is available as a separate download
from RHN.  boot.iso is an ISO 9660 image of a bootable CD-ROM.  It is useful
in cases where the CD-ROM installation method is not desired, but the
CD-ROM's boot speed would be an advantage.

To use this image file, burn the file onto CD-R (or CD-RW) media as you
normally would.

It is also possible to use boot.iso to create bootable USB media.  To do
so, use the dd utility to copy the boot.iso content to the USB media.
Detailed instructions can be found in the Red Hat Enterprise Linux 6
Installation Guide.



This is with 20110210.1 build.
Comment 14 errata-xmlrpc 2011-05-19 08:55:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0540.html

Note You need to log in before you can comment on or make changes to this bug.