Bug 587888 - OSAD / Up2date throws an error when trying to upgrade packages
Summary: OSAD / Up2date throws an error when trying to upgrade packages
Status: CLOSED DUPLICATE of bug 589120
Alias: None
Product: Spacewalk
Classification: Community
Component: Clients   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: space11
TreeView+ depends on / blocked
 
Reported: 2010-05-01 11:21 UTC by Holger Latz
Modified: 2012-03-06 09:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 13:54:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Holger Latz 2010-05-01 11:21:00 UTC
Description of problem:

Since I upgraded from 0.8 the OSAD package deployment does not work anymore. It seems to be a problem with the Python code.


How reproducible:

Just schedule a package upgrade for a client on the SW-Server.

  
Actual results:

On the Spacework-Server the Schedule-Screen tells: 

'Fatal error in Python code occured [[6]]'

On the Client in up2date.log:

Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 283, in __run_action
    (status, message, data) = CheckCli.__do_call(method, params)
  File "/usr/sbin/rhn_check", line 275, in __do_call
    method = getMethod.getMethod(method, "/usr/share/rhn/", "actions")
  File "/usr/share/rhn/up2date_client/getMethod.py", line 78, in getMethod
    actions = __import__(modulename)
  File "/usr/share/rhn/actions/packages.py", line 266, in ?
    yum_base = YumAction()
  File "/usr/share/rhn/actions/packages.py", line 62, in __init__
    self.doConfigSetup(debuglevel=rhncli.cfg["debug"])
exceptions.AttributeError: 'module' object has no attribute 'cfg'

Comment 1 Jan Pazdziora 2010-05-05 13:54:49 UTC
Justin is addressing this in bug 589120.

*** This bug has been marked as a duplicate of bug 589120 ***


Note You need to log in before you can comment on or make changes to this bug.