Bug 589120 - Traceback on rhn_check "no attribute 'cfg'"
Traceback on rhn_check "no attribute 'cfg'"
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Red Hat Satellite QA List
:
: 587888 (view as bug list)
Depends On:
Blocks: space10 591080
  Show dependency treegraph
 
Reported: 2010-05-05 08:43 EDT by Sandro Mathys
Modified: 2010-11-20 09:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 591080 (view as bug list)
Environment:
Last Closed: 2010-11-20 09:05:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mathys 2010-05-05 08:43:25 EDT
/var/log/up2date says:
[Wed May  5 13:43:17 2010] up2date 
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 283, in __run_action
    (status, message, data) = CheckCli.__do_call(method, params)
  File "/usr/sbin/rhn_check", line 275, in __do_call
    method = getMethod.getMethod(method, "/usr/share/rhn/", "actions")
  File "/usr/share/rhn/up2date_client/getMethod.py", line 78, in getMethod
    actions = __import__(modulename)
  File "/usr/share/rhn/actions/packages.py", line 266, in <module>
    yum_base = YumAction()
  File "/usr/share/rhn/actions/packages.py", line 62, in __init__
    self.doConfigSetup(debuglevel=rhncli.cfg["debug"])
<type 'exceptions.AttributeError'>: 'module' object has no attribute 'cfg'

I *think* this results in:
Client execution returned "Fatal error in Python code occured [[6]]" (code -1)
in the WebUI for all events (i.e. anything that runs through rhn_check) even if the task is successful (i.e. rhn_check -vvv does). The traceback might be unrelated to this tho.

Version:
rhn-check-1.0.0-1.fc12.noarch

Additional Information:
<roysjosh> red_alert, jsherrill, seems like this commit is responsible for your traceback: 2fa678d4153e2a072d8c1953c3c5a16b7a1d080c
<roysjosh> it removes cfg from up2date_client/rhncli.py
Comment 1 Jan Pazdziora 2010-05-05 08:51:55 EDT
Actually, it's 8d915a17b46d5e83a1b06d60b51c0e7ed36bf714 which seems to be out of line.
Comment 2 Sandro Mathys 2010-05-05 08:56:27 EDT
Additional tests show that this definitely happens in different cases:
- applying updates
- deploying config files

Also, if rhn_check is called with -vvv the following is always logged just after the traceback:
[Wed May  5 14:57:59 2010] up2date D: local action status:  ((6,), 'Fatal error in Python code occured', {})

So I guess those two things are really only one problem.
Comment 3 Justin Sherrill 2010-05-05 09:08:47 EDT
went ahead and added the cfg back into rhncli.py

master:
a437034484fb40034f59c209bb95f0c912776519

spacewalk 1.0 backport:
bfa90ae335a79f88390d20894eed52bb0900c4b4
Comment 4 Jan Pazdziora 2010-05-05 09:54:49 EDT
*** Bug 587888 has been marked as a duplicate of this bug. ***
Comment 5 Justin Sherrill 2010-05-05 11:11:09 EDT
Packages built:

yum-rhn-plugin-1.0.2-1
rhn-client-tools-1.0.6-1
Comment 6 Justin Sherrill 2010-05-05 16:34:23 EDT
Changed the fix a little:

da27aded48e9710465a55a72d845d23779005a8d
Comment 8 Sandro Mathys 2010-05-21 04:34:07 EDT
This is definitely fixed in 1.0 and nightly, thanks.
Comment 9 Jan Pazdziora 2010-11-20 09:05:48 EST
(In reply to comment #8)
> This is definitely fixed in 1.0 and nightly, thanks.

Aligning to space10 and closing.

Note You need to log in before you can comment on or make changes to this bug.