Bug 587929 - GDM fails to allow password field selection after changing focus
Summary: GDM fails to allow password field selection after changing focus
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: jmccann
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
: 598918 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-01 15:57 UTC by Jason Roysdon
Modified: 2015-01-14 23:25 UTC (History)
5 users (show)

Fixed In Version: gdm-2.30.2-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 20:27:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 619963 None None None Never

Description Jason Roysdon 2010-05-01 15:57:58 UTC
Description of problem:
GDM logon screen fails to allow password field selection after changing focus.

Version-Release number of selected component (if applicable):
RHEL6.0 Beta 1

How reproducible:


Steps to Reproduce:
1. After booting to GUI logon screen, select a userid to login as (do not enter password).
2. Select Universal Access Preferences or Boot Messages icons.
3. Select Close option.
4. Try to select Password field or logon box, and focus will not change.
  
Actual results:
At step 4 the only working option is to Cancel the login request.


Expected results:
Focus should change to the logon box and allow password to be entered.


Additional info:
If Language or Country options are selected and then closed out of, this bug doesn't occur.  Those boxes must handle things differently (correct).

Comment 2 RHEL Product and Program Management 2010-05-01 17:13:14 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 jmccann 2010-06-02 20:13:11 UTC
*** Bug 598918 has been marked as a duplicate of this bug. ***

Comment 4 jmccann 2010-06-07 21:20:06 UTC
Fix has been committed to upstream master.  Need a qa ack here.

Comment 5 Ray Strode [halfline] 2010-06-14 15:05:55 UTC
should be set in gdm-2.30.2-8.el6

Comment 7 Vladimir Benes 2010-08-04 13:01:53 UTC
can login successfully after going through boot messages no clicks needed, password prompt has focus automatically
-> VERIFIED

Comment 8 releng-rhel@redhat.com 2010-11-10 20:27:36 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.