Bug 58795 - Keyboard lockups with SysVinit 2.79
Keyboard lockups with SysVinit 2.79
Product: Red Hat Raw Hide
Classification: Retired
Component: SysVinit (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: 57482 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2002-01-24 15:06 EST by Sammy
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-02-16 13:26:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sammy 2002-01-24 15:06:21 EST
Since the introduction of 2.79 a number of people have been experiencing
intermittent keyboard lockups. The problem happened everytime a tty was
respawned e.g. a modem line running on ttyS0. When a call came in, keyboard
died, if one turned off the modem (AA mode) keyboard died, if one did telinit q,
telinit u, keyboard died. Restarting X11 solved the problem (mouse kept working).
Apparently there is some kind of a race condition for the keyboard.

SOLUTION: Upgrading to sysvinit 2.84 and applying only the patches:

sysvinit-2.78-md5.patch (remove second hunk as it is already in)

Three of the other patches have been already incorporated into the package
(see ChangeLog).

After installing 2.84 none of the lockups happen anymore and everything is working
as expected.

Comment 1 Bill Nottingham 2002-01-25 02:12:15 EST
*** Bug 57482 has been marked as a duplicate of this bug. ***
Comment 2 Sammy 2002-02-07 10:53:02 EST
I have been waiting to see the upgrade (or downgrade) of the SysVinit-2.79 in
rawhide but so far it is not. 2.79 is buggy as it is mentioned in the later upgrades.
I also looked and no distro is using 2.79 except rawhide. I think we should either
go back to 2.78 or go upto 2.8x. Just a reminder!
Comment 3 CoreDump 2002-02-16 13:25:59 EST
Going back to SysVinit 2.78-17 solved my problem too.
Killing mingetty (forcing a respawn) when in X windows also reproduces this bug.
Comment 4 Bill Nottingham 2002-07-18 21:36:01 EDT
This *should* be fixed with the current 2.84-x; please reopen if it's not.

Note You need to log in before you can comment on or make changes to this bug.