Bug 587987 - Fedora-13-x86_64-DVD.iso: mounting /dev/sr0 as /mnt/source: mount failed: (9, None)
Fedora-13-x86_64-DVD.iso: mounting /dev/sr0 as /mnt/source: mount failed: (9,...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-01 21:17 EDT by Nick Urbanik
Modified: 2011-06-27 12:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 12:01:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log taken after error message appears (6.95 KB, text/plain)
2010-05-03 17:44 EDT, Nick Urbanik
no flags Details
/tmp/syslog taken after the error appeared. (67.83 KB, text/plain)
2010-05-03 17:45 EDT, Nick Urbanik
no flags Details
A tarball of all the files from /tmp after the error appeared. (39.25 KB, application/x-bzip2)
2010-05-03 17:51 EDT, Nick Urbanik
no flags Details

  None (edit)
Description Nick Urbanik 2010-05-01 21:17:00 EDT
Description of problem: mount on /mnt/source fails in upgrade of existing F11 system on an iMac 27 inch.


Version-Release number of selected component (if applicable): anaconda 13.37.2


How reproducible: always


Steps to Reproduce:
1. Boot Fedora-13-Beta-x86_64-DVD.iso from DVD drive, selecting Install system with basic video driver
2. Select English language, US keyboard, "Install anyway", "Basic Storage Devices", check next to model "ATA ST31000528ASQ", "Upgrade an Existing System"
3. Select "Upgrade an Existing System", where "Fedora 11 (installed on /dev/mapper/vg_hostname-LogVol00)" is selected.
  
Actual results: A box appears saying, "An error occurred mounting /dev/sr0 as /mnt/source: mount failed: (9, None).
This is a fatal error and the install cannot continue."

Expected results: upgrading should work.

Additional info: After the error box appears,
on the console (Alt-Ctrl-F2), I type:
mount|grep sr0
and get:
/dev/sr0 on /mnt/stage2 type iso9660 (ro,relatime).
When I type:
mkdir /mnt/source
mount /dev/sr0 /mnt/source
I get:
mount: /dev/sr0 already mounted or /mnt/source is busy
mount: according to mtab, /dev/sr0 is mounted on /mnt/stage2
Comment 1 Chris Lumens 2010-05-02 22:44:14 EDT
Please attach /tmp/syslog and /tmp/anaconda.log to this bug report.  Thanks.
Comment 2 Nick Urbanik 2010-05-03 17:44:59 EDT
Created attachment 411138 [details]
anaconda.log taken after error message appears
Comment 3 Nick Urbanik 2010-05-03 17:45:55 EDT
Created attachment 411139 [details]
/tmp/syslog taken after the error appeared.
Comment 4 Nick Urbanik 2010-05-03 17:51:40 EDT
Created attachment 411141 [details]
A tarball of all the files from /tmp after the error appeared.

I've added this tarball as it includes further evidence of what is happening, possibly missing from the anaconda.log and syslog files alone.
Comment 5 Nick Urbanik 2010-05-16 02:53:28 EDT
If I can offer any more details, I am happy to do so.  Seems that it
should be a release blocker if you cannot upgrade on a particular
common hardware platform.
Comment 6 Nick Urbanik 2010-05-23 02:24:43 EDT
I confirm that this problem is unresolved with the final release of
Fedora 13.  The same error message appears.  I need a work around
since my wife and son will be stuck with unsupported Fedora 11 till
then.
Comment 7 Nick Urbanik 2010-05-23 02:28:26 EDT
With Fedora 13, the problem now applies to Anaconda 13.42.
Comment 8 Nick Urbanik 2010-05-23 03:44:00 EDT
On another machine, running Fedora 12:
$ mount | grep sr0
/dev/sr0 on /media/Fedora 13 x86_64 DVD type iso9660 (rw,nosuid,nodev,uhelper=hal,uid=1000,utf8)
$ mkdir /tmp/1
$ sudo mount /dev/sr0 /tmp/1
mount: /dev/sr0 already mounted or /tmp/1 busy
mount: according to mtab, /dev/sr0 is mounted on /media/Fedora 13 x86_64 DVD

Now I expected that I should be able to mount a DVD twice.
Clearly, that is what anaconda is trying to do (and its failure
to do so is the error).

But I can mount other file systems twice, but not a DVD, except
with --bind mounts, which anaconda will not do (unless I modify
its code).

1. Is it correct that the kernel will only allow one mount of a DVD?
2. If not, why does anaconda want to do so?
3. If so, why can I not do it on Fedora 11, 12 and 13?
Comment 9 Radek Vykydal 2010-07-20 12:28:32 EDT
Can you please post contents of /etc/fstab from the system you are attempting to upgrade?
Comment 10 hous21 2010-08-09 11:00:44 EDT
I am using preupgrade from fedora 11.
I got the same error
This may be similar to:
Bug 507433

posting contents of /etc/fstab:
#
# /etc/fstab
# Created by anaconda on Mon Jun 29 19:18:10 2009
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
#
UUID=c03acee8-79af-4af3-8b47-ccb48b7a8354 /boot                   ext3    defaults        1 2
/dev/mapper/vg_houssam-lv_root /                       ext4    defaults        1 1
/dev/mapper/vg_houssam-lv_swap swap                    swap    defaults        0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620        0 0
#devpts options modified by setup update to fix #515521 ugly way
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/sda1               /mnt/WinC               ntfs    users,rw,sync  0 0
#/dev/sda1              /mnt/WinC               ntfs    users,noexec,ro,sync  0 0
(In reply to comment #9)
> Can you please post contents of /etc/fstab from the system you are attempting
> to upgrade?    

(In reply to comment #9)
> Can you please post contents of /etc/fstab from the system you are attempting
> to upgrade?
Comment 11 Bug Zapper 2011-06-02 10:37:50 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2011-06-27 12:01:07 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.