Bug 588163 - Manual IPv6 configures SLAAC as well
Summary: Manual IPv6 configures SLAAC as well
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: 12
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 588149 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-02 22:10 UTC by Scott Schmit
Modified: 2010-05-04 11:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 11:31:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Scott Schmit 2010-05-02 22:10:57 UTC
Description of problem:
When configuring a connection with manual IPv6, connecting to the network results in SLAAC addresses as well as the manual one(s).

On one hand, IPv6 isn't like IPv4 -- you can have multiple addresses on your interface, so the extra addresses are probably harmless, but I can imagine where people would find the extra addresses to be undesirable (POLA/tradition, don't want the machine to respond to an Internet-accessible address, manual addresses interfere somehow with the SLAAC, etc).

Version-Release number of selected component (if applicable):
NetworkManager-0.8.0-10.git20100502.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Configure a connection to have the IPv6 method set to manual (IPv4 to whatever you want -- disable is probably the least distracting)
2. Connect to that connection
3. Look at ip addr, ip -6 route, /etc/resolv.conf
  
Actual results:
SLAAC addresses and routes are configured

Expected results:
SLAAC addresses and routes are not configured, and must be manually configured if desired. (I'm not counting the Link Local address as SLAAC here)

Additional info:

Comment 1 Dan Williams 2010-05-03 10:11:48 UTC
*** Bug 588149 has been marked as a duplicate of this bug. ***

Comment 2 Dan Williams 2010-05-03 10:12:42 UTC
So accept_ra isn't getting set back to 0 when we're using manual mode, that's the problem here I believe.

Comment 3 Dan Williams 2010-05-03 10:43:50 UTC
Upstream fix is 7926b3ca95f2c0c611e271f805437cca9dc004ea.

Comment 4 Scott Schmit 2010-05-04 11:31:09 UTC
I can confirm that this now works with NetworkManager-0.8.0-11.git20100503.fc12.x86_64


Note You need to log in before you can comment on or make changes to this bug.