Bug 588178 - luci package is missing requires on dynforms
Summary: luci package is missing requires on dynforms
Status: CLOSED DUPLICATE of bug 586278
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On: 542613
Blocks: 553388
TreeView+ depends on / blocked
 
Reported: 2010-05-03 01:25 UTC by Subhendu Ghosh
Modified: 2016-10-04 04:32 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 542613
Environment:
Last Closed: 2010-05-05 18:52:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Subhendu Ghosh 2010-05-03 01:25:22 UTC
+++ This bug was initially created as a clone of Bug #542613 +++

Description of problem:

actually starting luci properly fails:
/usr/lib/python2.6/site-packages/tw/core/view.py:223: DeprecationWarning: object
.__new__() takes no parameters
  obj = object.__new__(cls, *args, **kw)
Starting server in PID 18908.
serving on http://127.0.0.1:8080
Error - <type 'exceptions.ImportError'>: No module named dynforms

Version-Release number of selected component (if applicable):
luci-0.21.0-5.fc12.noarch

How reproducible:
always

Additional info:
i think the required dynforms package is not even yet in fedora.

--- Additional comment from lhh@redhat.com on 2010-01-07 14:02:59 EST ---

Need to know if this should be cloned for RHEL6 and the impact:

- is dynforms python module in RHEL6 / does it need to be?
- has this been resolved in another way?

--- Additional comment from rmccabe@redhat.com on 2010-01-07 14:05:39 EST ---

Chris and I discussed this, and decided that it was best to just include that library with luci. It's pretty small (just provides an widget for a form that automatically grows fields).

The error is probably a packaging error (my fault). I'll look into it.

--- Additional comment from justin@salasaga.org on 2010-05-01 12:14:57 EDT ---

As mentioned by Kith Wright in bug #563372, a workaround for now is to use easy_install to install tw.dynforms:

$ sudo easy_install tw.dynforms
Searching for tw.dynforms
Reading http://pypi.python.org/simple/tw.dynforms/
Reading http://pajhome.org.uk/
Best match: tw.dynforms 0.9.8
Downloading http://pypi.python.org/packages/source/t/tw.dynforms/tw.dynforms-0.9.8.tar.gz#md5=188aafe67667f291812f4382a51eb7f8
Processing tw.dynforms-0.9.8.tar.gz
Running tw.dynforms-0.9.8/setup.py -q bdist_egg --dist-dir /tmp/easy_install-qBVIe2/tw.dynforms-0.9.8/egg-dist-tmp-U9VZuF
Adding tw.dynforms 0.9.8 to easy-install.pth file

Installed /usr/lib/python2.6/site-packages/tw.dynforms-0.9.8-py2.6.egg
Processing dependencies for tw.dynforms
Finished processing dependencies for tw.dynforms
$

Doing this, then restarting the luci service (required) then allowed the local web interface to function.

--- Additional comment from justin@salasaga.org on 2010-05-01 13:28:49 EDT ---

This bug is also present in RHEL 6 public beta.

Comment 1 RHEL Product and Program Management 2010-05-03 01:53:04 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Justin Clift 2010-05-03 01:55:44 UTC
It may be worth mentioning that even after installing the dynforms Python module as indicated above, luci doesn't really work.  The web interface loads, however any form that's submitted fails with an "unknown keyword" error on whatever variable was being submitted.

luci was de-installed from the test lab boxes yesterday, so my apologies about this low quality bug update and not being able to provide the exact error message. :(

Comment 3 Perry Myers 2010-05-03 09:42:51 UTC
Just to be clear, luci in beta1 was in non working condition as we still had major development effort to do on it at that point.  We are expecting it to be in working condition for the next beta.

Comment 4 Bill Nottingham 2010-05-05 18:52:01 UTC

*** This bug has been marked as a duplicate of bug 586278 ***


Note You need to log in before you can comment on or make changes to this bug.