Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 588207 - Logical volume name is invalid
Summary: Logical volume name is invalid
Keywords:
Status: CLOSED DUPLICATE of bug 600639
Alias: None
Product: Fedora
Classification: Fedora
Component: schroot
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Zach Carter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 588200
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-03 07:01 UTC by Oron Peled
Modified: 2010-06-09 16:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-09 16:37:43 UTC
Type: ---


Attachments (Terms of Use)

Description Oron Peled 2010-05-03 07:01:38 UTC
Description of problem:
Using schroot with type=lvm-snapshot fails because the snapshot
logical volume name chosen by schroot is illegal.

Version-Release number of selected component (if applicable):
schroot-1.2.3-3.fc12.i686

How reproducible:
Create an lvm-snapshot schroot (for example, like in bug #588200).
Trying to enter this schroot fails.

Actual results:
Running:
 [root@argon schroot]# schroot -c lenny-i386
 Logical volume name "lenny-i386-2010-05-03T06:33:59Z-31230" is invalid
 Run `lvcreate --help' for more information.
 E: lenny-i386-2010-05-03T06:33:59Z-31230: Chroot setup failed: stage=setup-start

Expected results:
A snapshot logical volume of the chroot should have been created and that
schroot should enter into the chroot environment.

Additional info:
Entering the source (not snapshot) of the same schroot works:
 [root@argon ~]# schroot -c lenny-i386-source
 I: [lenny-i386-source chroot] Running login shell: ‘/bin/bash’

Searching for the limitation, I bumped across this relevant bug report:
http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg476634.html

Comment 1 Zach Carter 2010-06-09 16:37:43 UTC

*** This bug has been marked as a duplicate of bug 600639 ***


Note You need to log in before you can comment on or make changes to this bug.