Bug 600639 - fails lvm-snapshot schroot (snapshot-name)
fails lvm-snapshot schroot (snapshot-name)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: schroot (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Zach Carter
Fedora Extras Quality Assurance
:
: 588207 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-05 07:03 EDT by Oron Peled
Modified: 2010-06-28 13:19 EDT (History)
2 users (show)

See Also:
Fixed In Version: schroot-1.2.3-5.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 13:11:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oron Peled 2010-06-05 07:03:31 EDT
Description of problem:
Fails to create a schroot with type=lvm-snapshot because the default
logical name of the created snapshot is illegal.

Version-Release number of selected component (if applicable):
schroot-1.2.3-8.fc13.i686 + applied workaround from bug #600636

Steps to Reproduce:
1. Use the same schroot definition as in bug #600636
2. Try to enter this schroot:
    [oron@radon ~]$ schroot -c test-f13
    E: test-f13-2010-06-05T09:55:21Z-532: Failed to lock chroot: /dev/vg_radon/lv_f-13: Failed to lock device: Failed to lock device

Additional info:
1. The problem is the ':' is an illegal character in logical volume name.
   This can be easily verified by trying to create one manually (as root):
   lvcreate -n "foo:bar" vol_group_name
2. The name is created in session::run_impl() (line 547)
3. The code can generate UUID based name instead, which solves the problem:
   - Simply adding "BuildRequires: libuuid-devel" to schroot.spec is good.
     (when configure detects libuuid headers, it uses this code)
   - Debian lenny also use it as can be seen from the lvm-snapshot names
     generated.
4. I still think the non-libuuid code is an upstream bug.
Comment 1 Zach Carter 2010-06-06 11:01:48 EDT
Thanks Oron.

This bug was already reported upstream on 5/30 as debian bug #583504.

The BuildRequires: libuuid-devel workaround is already in place in the rawhide version of schroot.  I'll try to get an update into F13 and F12 soon.
Comment 2 Roger Leigh 2010-06-07 18:30:51 EDT
While having a libuuid-devel BR will fix this nicely, I've also fixed the underlying issue in upstream git and this should be in a new release within the week once I've done some further testing.  I've basically switched from using ISO-8601-formatted dates to UNIX time [time(2)] output for chroot session names in the absence of UUID support.  This has the same time resolution, but won't use the illegal characters seen in the ISO-8601 date.


Regards,
Roger
Comment 3 Fedora Update System 2010-06-08 15:13:01 EDT
schroot-1.2.3-9.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/schroot-1.2.3-9.fc13
Comment 4 Zach Carter 2010-06-09 12:37:43 EDT
*** Bug 588207 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2010-06-09 15:59:13 EDT
schroot-1.2.3-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/schroot-1.2.3-5.fc12
Comment 6 Fedora Update System 2010-06-10 15:11:44 EDT
schroot-1.2.3-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update schroot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/schroot-1.2.3-5.fc12
Comment 7 Fedora Update System 2010-06-10 15:12:09 EDT
schroot-1.2.3-9.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update schroot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/schroot-1.2.3-9.fc13
Comment 8 Fedora Update System 2010-06-28 13:11:38 EDT
schroot-1.2.3-9.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-06-28 13:19:42 EDT
schroot-1.2.3-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.