Bug 588319 - f13 new icons for setroubleshoot
f13 new icons for setroubleshoot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: f13artwork
  Show dependency treegraph
 
Reported: 2010-05-03 09:30 EDT by Máirín Duffy
Modified: 2010-05-10 10:49 EDT (History)
6 users (show)

See Also:
Fixed In Version: setroubleshoot-2.2.81-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 01:47:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
new icons for setroubleshoot (3.90 KB, application/x-bzip2)
2010-05-03 09:30 EDT, Máirín Duffy
no flags Details
icons with a red bolt for critical setroubleshoot alerts (3.85 KB, application/x-bzip)
2010-05-04 15:33 EDT, Máirín Duffy
no flags Details
new icons, including the plain and criticals (22.08 KB, application/x-bzip)
2010-05-06 15:58 EDT, Máirín Duffy
no flags Details
comp showing new icons in PNG format for quick viewing (16.75 KB, image/png)
2010-05-06 16:01 EDT, Máirín Duffy
no flags Details
sorry i forgot the scalable versions in the last upload (29.37 KB, application/x-bzip)
2010-05-06 16:13 EDT, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2010-05-03 09:30:59 EDT
Created attachment 410986 [details]
new icons for setroubleshoot

Description of problem:

The current setroubleshoot icons are bluecurve and outdated. Here's some icons created to match the rest of the Fedora icon theme.
Comment 1 Máirín Duffy 2010-05-04 15:33:02 EDT
Created attachment 411388 [details]
icons with a red bolt for critical setroubleshoot alerts
Comment 2 Máirín Duffy 2010-05-04 15:33:31 EDT
just a note, these icons aren't from upstream, I created them specifically for setroubleshoot from scratch. Whatever license / etc works is fine.
Comment 3 Daniel Walsh 2010-05-04 16:07:38 EDT
We are upstream
Comment 4 Máirín Duffy 2010-05-04 20:46:21 EDT
Hi Dan! Sorry for the vague comment. I meant the upstream gnome-icon-theme project, which these icons are attempting to fit in with!
Comment 5 Paul W. Frields 2010-05-05 14:44:06 EDT
Hi Dan, is there a new build coming with these icons fixed?  We're at the wire to get blocking bugs fixed, and this is one of them according to our release criteria:

https://fedoraproject.org/wiki/Fedora_13_Final_Release_Criteria

Thanks for your time as always.
Comment 6 Daniel Walsh 2010-05-05 16:52:24 EDT
Paul, I am afraid this one is waiting on Máirín, as soon as she gets me icons, I will build a package.
Comment 7 Daniel Walsh 2010-05-05 18:20:43 EDT
Updated in setroubleshoot-2.2.79-1.fc13

Please test....
Comment 8 Kamil Páral 2010-05-06 08:11:45 EDT
(In reply to comment #7)
> Updated in setroubleshoot-2.2.79-1.fc13
> 
> Please test....    

The menu item is updated. The browser frame does has only stock (=no) icon, is that correct?

How can I trigger some alert so I see the notification area applet?
Comment 9 James Laska 2010-05-06 08:16:17 EDT
(In reply to comment #7)
> Updated in setroubleshoot-2.2.79-1.fc13
> 
> Please test....    

Confirmed new icon for "Applications -> System Tools -> SELinux troubleshooter "

Confirmed kparal's finding that the application icon does not match.

Also, please note that a bodhi update will need to be submitted for this fix to arrive in Fedora 13.  Thanks!
Comment 10 Daniel Walsh 2010-05-06 08:59:03 EDT
No that is a bug.


sandbox rpm -qa 

Should trigger avc messages
Comment 11 Daniel Walsh 2010-05-06 09:47:29 EDT
Updated in setroubleshoot-2.2.80-1.fc13
Comment 12 Fedora Update System 2010-05-06 09:49:48 EDT
setroubleshoot-2.2.80-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/setroubleshoot-2.2.80-1.fc13
Comment 13 Kamil Páral 2010-05-06 10:14:28 EDT
Ok, now even application has the icon. I don't like it being so blurry. 24x24px is good for menu item, but not for application icon (when switching between apps). Also scalable icon should be present, I suppose it was done as vector icon anyway.

'sandbox rpm -qa' did not trigger any AVCs, so I couldn't test the applet. Any other way?
Comment 14 Daniel Walsh 2010-05-06 10:46:56 EDT
Kamil, The icon developers are working to get me a larger icon.  As of now the best I have is 24x24.

Will fix when new icons are ready.  You might need to logout to get new version to work.  Or kill and restart seapplet.
Comment 15 Máirín Duffy 2010-05-06 15:58:31 EDT
Created attachment 412147 [details]
new icons, including the plain and criticals
Comment 16 Máirín Duffy 2010-05-06 16:01:39 EDT
Created attachment 412149 [details]
comp showing new icons in PNG format for quick viewing
Comment 17 Máirín Duffy 2010-05-06 16:13:31 EDT
Created attachment 412152 [details]
sorry i forgot the scalable versions in the last upload
Comment 18 Daniel Walsh 2010-05-06 17:12:13 EDT
Updated in setroubleshoot-2.2.81-1.fc13
Comment 19 Fedora Update System 2010-05-07 01:47:16 EDT
setroubleshoot-2.2.81-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Kamil Páral 2010-05-07 02:31:19 EDT
The new icon set is present. Unfortunately I wasn't able to test notification area applet, because I don't know how to trigger avc messages (sandbox rpm -qa doesn't work).
Comment 21 Daniel Walsh 2010-05-07 16:47:48 EDT
kamil log out and log back in should start the process again.
Comment 22 Kamil Páral 2010-05-10 05:16:21 EDT
(In reply to comment #21)
> kamil log out and log back in should start the process again.    

I have done complete machine reboot after setroubleshoot upgrade. That command does not trigger any avc denials for me. It just prints "error: cannot open Packages database in /var/lib/rpm" twice. Nothing in audit.log either.
Comment 23 Daniel Walsh 2010-05-10 10:28:28 EDT
Make sure auditing is running.

service auditd restart

There is some bugs in readahead that can turn off the audit subsystem.

Are you seeing avc messages in /var/log/messages?
Comment 24 Kamil Páral 2010-05-10 10:49:01 EDT
Oh, that was it, auditd was not configured to run. Ok, now it throws avc messages and applet icon looks good, thanks. Verified.

Note You need to log in before you can comment on or make changes to this bug.