Bug 588486 - can't send email to a trusted AD domain
can't send email to a trusted AD domain
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-mapi (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
: 662055 667167 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 15:41 EDT by Chad Feller
Modified: 2011-01-05 09:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 02:36:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug output (13.23 KB, application/x-gzip)
2010-05-04 18:43 EDT, Chad Feller
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 621064 None None None Never

  None (edit)
Description Chad Feller 2010-05-03 15:41:29 EDT
Description of problem:
When sending a message to a trusted AD domain, message sits in outbox.

Version-Release number of selected component (if applicable):

evolution-2.30.1-2.fc13.x86_64
evolution-mapi-0.30.1-1.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. send message to user on trusted AD domain
2.
3.
  
Actual results:
message sits in outbox

Expected results:
message is sent

Additional info:
console output when send is attempted:

0xbf33d0: 1 0 0 | 0 0 0 
0xbf33d0: 1 0 0 | 1 1 1
 Searching for added matches '(match-all (system-flag "Deleted"))'

===========
DB SQL operation [BEGIN] started
Camel SQL Exec:
BEGIN
Vfolder '.#evolution/Trash' subfolder changed 'Outbox'
 changed 0 added 1 removed 0
Camel SQL Exec:
COMMIT
DB Operation ended. Time Taken : 0.000302
###########
 Searching for added matches '(match-all (system-flag "Junk"))'

===========
DB SQL operation [BEGIN] started
Camel SQL Exec:
BEGIN
Vfolder '.#evolution/Junk' subfolder changed 'Outbox'
 changed 0 added 1 removed 0
Camel SQL Exec:
COMMIT
DB Operation ended. Time Taken : 0.000187
###########
Thread 0 >
CamelFolder:get_message('Outbox', '456') =
class: CamelMimeMessage
mime-type: text/plain
content class: CamelDataWrapper
content mime-type: text/plain
< 0 >
Event : Message created
	Folder Entry ID: 0x7570700100000005
	Message Entry ID: 0xa041c6da2a000001
	 Tag: PR_HASATTACH
	 Tag: PR_TRUST_SENDER
	 Tag: PR_SEARCH_KEY
	 Tag: PR_LOCALE_ID
	 Tag: PR_MESSAGE_LOCALE_ID
	 Tag: PR_CREATION_TIME
	 Tag: PR_LAST_MODIFICATION_TIME
	 Tag: PR_LOCAL_COMMIT_TIME
	 Tag: PR_INTERNET_CPID
	 Tag: PR_SUBJECT_UNICODE
	 Tag: PR_SUBJECT_PREFIX_UNICODE
	 Tag: PR_NORMALIZED_SUBJECT_UNICODE
	 Tag: PR_CONVERSATION_TOPIC_UNICODE
	 Tag: PR_SEND_RICH_INFO
	 Tag: PR_MESSAGE_FLAGS
	 Tag: PR_INTERNET_MESSAGE_ID
	 Tag: PR_BODY_UNICODE
	 Tag: PR_RTF_COMPRESSED
	 Tag: PR_HTML
	 Tag: PR_RTF_IN_SYNC
	 Tag: PR_MESSAGE_CODEPAGE
	 Tag: PR_CLIENT_SUBMIT_TIME
	 Tag: PR_MESSAGE_DELIVERY_TIME
	 Tag: PR_MESSAGE_SIZE
	 Tag: PR_INTERNET_ARTICLE_NUMBER
Event : Message deleted
	Folder Entry ID: 0x7570700100000005
	Message Entry ID: 0xa041c6da2a000001
Event : Message modified
	Folder Entry ID: 0x7570700100000005
	Message Entry ID: 0xa041c6da2a000001
Event : Message moved
	Folder Entry ID: 0x7570700100000005
	Message Entry ID: 0xa041c6da2a000001
	Old Parent Folder Entry ID: 0x0
	Old Message Entry ID: 0x0
Event : Message copied
	Folder Entry ID: 0x7570700100000005
	Message Entry ID: 0xa041c6da2a000001
	Old Parent Folder Entry ID: 0x0
	Old Message Entry ID: 0x0
Event : Message created
	Folder Entry ID: 0x7570700100000005
	Message Entry ID: 0xa041c6da2a000001
CamelException.setv(0x7f6cc3739b70, 303, 'Could not send message.')
Comment 1 Chad Feller 2010-05-03 15:47:42 EDT
additionally:
while trying to debug this problem, I produced this crash (twice): bug #588439.
Comment 2 Milan Crha 2010-05-04 07:33:37 EDT
Thanks for a bug report.

(In reply to comment #1)
> additionally:
> while trying to debug this problem, I produced this crash
> (twice): bug #588439.    

As I reported on that bug, it's because of CAMEL_DEBUG you used. I added an upstream bug link there as well.

> ---------------------------------------------------------------------------

With respect of this bug, please try with this debugging on:
EXCHANGEMAPI_DEBUG=1
MAPI_DEBUG=1
you can try also with MAPI_DEBUG=10, but it's too chatty, it shows the whole communication and private data. Either consult that log, or upload it here, but take care of things you do not want to share publicly.

When you say "sending a message to a trusted AD domain", what does it mean exactly? Is it like filling only username of a user which is on the server to the recipient list (To/CC)? It seem to work fine for me.
Comment 3 Chad Feller 2010-05-04 17:44:28 EDT
(In reply to comment #2)
> When you say "sending a message to a trusted AD domain", what does it mean
> exactly? Is it like filling only username of a user which is on the server to
> the recipient list (To/CC)? It seem to work fine for me.    

We have domain1 and domain2, there is a two-way trust between domain1 and domain2.  I'm in domain1, and was trying to send a message to user in domain2.
Comment 4 Chad Feller 2010-05-04 18:43:15 EDT
Created attachment 411423 [details]
debug output

created	with:
EXCHANGEMAPI_DEBUG=1
MAPI_DEBUG=1
Comment 5 Chad Feller 2010-05-04 18:46:41 EDT
In parsing through that output while I was scrubbing it, I noticed that it kept saying:

  error_code               : ecUnknownUser (0x3EB)

which is probably what is causing it to choke.  Evolution is talking to the trusted domain fine though, as I can see all of domain2 users in GAL.  So it would seem that the GAL code is handling the trusted domain fine, but the mail code isn't?
Comment 6 Milan Crha 2010-05-05 06:46:52 EDT
I see that line too, but it's rather a "first try", then it tries to find the user, and it seems to succeed. but later on:
> SubmitMessage            : ecInvalidRecips (0x467)
so even it found him the server rejected him.

Are you using autocompletion when entering Joe's email, or you put in just his name and let it resolve the right name before sending? I would guess using his full email address should work, and using his username only as well, as it works fine for me here, though my server communicates with only one domain.

When you try to send an email to yourself, not using your email address, will it work or not?
Comment 7 Chad Feller 2010-05-12 15:43:31 EDT
(In reply to comment #6)

> Are you using autocompletion when entering Joe's email, or you put in just his
> name and let it resolve the right name before sending? I would guess using his
> full email address should work, and using his username only as well

I've tried letting autocomplete work (via GAL), I've tried manually entering his username@domain, and manually entering username (letting it resolve when I push send).  not one of those emails will send.

> works fine for me here, though my server communicates with only one domain.

right, the single domain issue, which affected me here in F11 and F12, was fixed with bug# 496702.  could this be related to that bug?
 
> When you try to send an email to yourself, not using your email address, will
> it work or not?    

autocomplete, manually entering my email address, and manually entering just my username all work to send myself a message.
Comment 8 Milan Crha 2010-05-13 07:11:28 EDT
Thanks for the update. I've unfortunately not much idea where to continue, maybe we can try with openchangeclient, whether it'll work or not. I suppose the same works just fine with Outlook.

Please create an openchangeclient profile, with a command like this:
   $ mapiprofile -S -P $PROFILENAME -c -I $SERVERADDRESS -u $USERNAME
      -p $PASSWORD -D $DOMAIN
which will create a default profile named as $PROFILENAME. It can be almost anything, so feel free to use a $USERNAME there as well. The other values are exactly the same as you entered while creating the MAPI account in Evolution.

Then you can run the openchangeclient:
   $ openchangeclient -S --to=$TO "--subject=test email" "--body=body of
       a test email"
where $TO is a name, or email address of the user in the second domain. Probably same as you see in Global Address List.
Comment 9 Chad Feller 2010-05-13 17:36:57 EDT
Created mapi profile, sent messages to myself, and I received them.  I was able to do this successfully whether I only specified 'user' or if I used 'user@domain'.

Furthermore these sent messages were also correctly copied to my "Sent Items" folder on exchange.

However, when I sent messages to the domain2 user, they seemed to vanish into thin air.  openchangeclient gave no indication that they didn't successfully send.  openchangeclient even returned 0.  The domain2 user didn't receive them, they didn't bounce back to me like they would if I specified a nonexistent user on domain1.  

Also, a copy of the email sent to the domain2 user wasn't left in my "Sent Items" folder like they were with the successful sends.

I tried to debug what was going on, but even setting --debug-level=10 didn't seem to change anything.  openchangeclient ran quietly.
Comment 10 Milan Crha 2010-06-09 02:36:53 EDT
I'm moving this to an upstream bug report [1] after our private conversation. Also, I just noticed, the --debug-level=10 should be --debuglevel=10 (without that middle dash), then the openchangeclient will print the output.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=621064
Comment 11 Milan Crha 2010-12-10 09:31:05 EST
*** Bug 662055 has been marked as a duplicate of this bug. ***
Comment 12 Milan Crha 2011-01-05 09:40:10 EST
*** Bug 667167 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.