Bug 588489 - memmove causes stack corruption on lossy network
Summary: memmove causes stack corruption on lossy network
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Steven Dake
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 588894 588895
TreeView+ depends on / blocked
 
Reported: 2010-05-03 19:45 UTC by Steven Dake
Modified: 2016-04-26 15:16 UTC (History)
5 users (show)

Fixed In Version: openais-0.80.6-18.el5
Doc Type: Bug Fix
Doc Text:
A memmove() operation on a high-loss network could have caused possible stack corruption resulting in stack protector abort due to an incorrectly-calculated length in the memmove() operation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 23:56:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that fixes stack corruption. (498 bytes, patch)
2010-05-03 19:51 UTC, Steven Dake
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0100 normal SHIPPED_LIVE openais bug fix update 2011-01-12 17:21:13 UTC

Description Steven Dake 2010-05-03 19:45:00 UTC
Description of problem:
a memmove on openais can cause stack corruption on a highly lossy network

Version-Release number of selected component (if applicable):
openais-0.80.6

How reproducible:
100%

Steps to Reproduce:
1. generate 90% packet loss (by instrumenting source code)
2. start 8 nodes with cpgverify
3. kill 1 node
  
Actual results:
crashes 

Expected results:
no crash

Additional info:

Comment 1 Steven Dake 2010-05-03 19:51:14 UTC
Created attachment 411105 [details]
patch that fixes stack corruption.

Comment 2 Nate Straz 2010-05-03 20:37:51 UTC
Is there a way to verify this without instrumenting the code?

Comment 9 Douglas Silas 2011-01-11 23:17:43 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
A memmove () operation on a high-loss network could have caused possible stack corruption resulting in stack protector abort due to an incorrectly-calculated length in the memmove() operation.

Comment 10 Jaromir Hradilek 2011-01-12 00:29:29 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-A memmove () operation on a high-loss network could have caused possible stack corruption resulting in stack protector abort due to an incorrectly-calculated length in the memmove() operation.+A memmove() operation on a high-loss network could have caused possible stack corruption resulting in stack protector abort due to an incorrectly-calculated length in the memmove() operation.

Comment 12 errata-xmlrpc 2011-01-13 23:56:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0100.html


Note You need to log in before you can comment on or make changes to this bug.