Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 588894 - memmove causes stack corruption on lossy network
memmove causes stack corruption on lossy network
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.5
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Steven Dake
Cluster QE
: ZStream
Depends On: 588489
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 15:16 EDT by Benjamin Kahn
Modified: 2016-04-26 12:19 EDT (History)
6 users (show)

See Also:
Fixed In Version: openais-0.80.6-8.el5_4.6
Doc Type: Bug Fix
Doc Text:
A memmove () operation on a high-loss network could have caused possible stack corruption resulting in stack protector abort due to an incorrectly-calculated length in the memmove() operation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 06:17:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backport of revision 2127 (498 bytes, patch)
2010-05-04 16:23 EDT, Steven Dake
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0485 normal SHIPPED_LIVE openais bug fix update 2010-06-16 06:17:41 EDT

  None (edit)
Description Benjamin Kahn 2010-05-04 15:16:35 EDT
This bug has been copied from bug #588489 and has been proposed
to be backported to 5.4 z-stream (EUS).
Comment 3 Steven Dake 2010-05-04 16:23:33 EDT
Created attachment 411403 [details]
backport of revision 2127
Comment 6 errata-xmlrpc 2010-06-16 06:17:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0485.html
Comment 7 Douglas Silas 2011-01-11 18:17:51 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
A memmove () operation on a high-loss network could have caused possible stack corruption resulting in stack protector abort due to an incorrectly-calculated length in the memmove() operation.

Note You need to log in before you can comment on or make changes to this bug.