Bug 588597 - DeviceError: ('device has not been created', 'sdb1')
Summary: DeviceError: ('device has not been created', 'sdb1')
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:baee4239821d52518...
Keywords:
Depends On:
Blocks: F13Blocker, F13FinalBlocker 592337
TreeView+ depends on / blocked
 
Reported: 2010-05-04 02:54 UTC by Jesse Keating
Modified: 2013-01-10 05:56 UTC (History)
6 users (show)

Fixed In Version: anaconda-13.41-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 592337 (view as bug list)
Environment:
Last Closed: 2010-05-12 01:03:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (280.60 KB, text/plain)
2010-05-04 02:54 UTC, Jesse Keating
no flags Details
Attached traceback automatically from anaconda. (277.70 KB, text/plain)
2010-05-05 18:17 UTC, Jesse Keating
no flags Details

Description Jesse Keating 2010-05-04 02:54:46 UTC
The following was filed automatically by anaconda:
anaconda 13.39 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 607, in setup
    raise DeviceError("device has not been created", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 2745, in setup
    member.setup(orig=orig)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 312, in execute
    self.device.setup(orig=True)
  File "/usr/lib/anaconda/storage/devicetree.py", line 696, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 283, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
DeviceError: ('device has not been created', 'sdb1')

Comment 1 Jesse Keating 2010-05-04 02:54:49 UTC
Created attachment 411171 [details]
Attached traceback automatically from anaconda.

Comment 2 Jesse Keating 2010-05-04 02:57:45 UTC
I got this when going from a system with two md devices to a default partitioning.

Tossing on the blocker list for visibility.

Comment 3 James Laska 2010-05-04 19:45:02 UTC
Same as bug#568759 ?

Comment 4 Jesse Keating 2010-05-04 21:00:20 UTC
Looks similar, but without knowing the root cause, hard to tell.  This may wind up being fixed by the other issue with md devices getting removed, so I'll wait until that bug is fixed and re-try.

Comment 5 Adam Williamson 2010-05-04 23:55:38 UTC
for me this is a blocker, per our criteria - any known fail at all when trying to set up a valid partition scheme counts as a blocker.

Comment 6 Jesse Keating 2010-05-05 18:17:22 UTC
Created attachment 411701 [details]
Attached traceback automatically from anaconda.

Comment 7 Jesse Keating 2010-05-05 18:18:31 UTC
Seems this is still happening with 13.40

Comment 8 James Laska 2010-05-06 22:10:30 UTC
There is an updates.img available to work around this issue.  The updates.img should be applied to anaconda-13.40-1

http://dlehman.fedorapeople.org/updates-588597.img

Comment 9 Jesse Keating 2010-05-06 22:25:29 UTC
Makes it work here.

Comment 10 Adam Williamson 2010-05-07 02:24:37 UTC
that would make it fixed in 13.41, right?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 11 Fedora Update System 2010-05-07 07:42:28 UTC
anaconda-13.41-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.41-1.fc13

Comment 12 Adam Williamson 2010-05-07 10:41:00 UTC
that makes this MODIFIED.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.