Bug 592337 - DeviceError: ('device has not been created', 'sdb1')
DeviceError: ('device has not been created', 'sdb1')
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Lehman
Release Test Team
anaconda_trace_hash:baee4239821d52518...
:
Depends On: 588597
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-14 11:28 EDT by David Lehman
Modified: 2010-11-10 14:43 EST (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.44-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 588597
Environment:
Last Closed: 2010-11-10 14:43:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2010-05-14 11:28:24 EDT
+++ This bug was initially created as a clone of Bug #588597 +++

The following was filed automatically by anaconda:
anaconda 13.39 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 607, in setup
    raise DeviceError("device has not been created", self.name)
  File "/usr/lib/anaconda/storage/devices.py", line 2745, in setup
    member.setup(orig=orig)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 312, in execute
    self.device.setup(orig=True)
  File "/usr/lib/anaconda/storage/devicetree.py", line 696, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 283, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
DeviceError: ('device has not been created', 'sdb1')

--- Additional comment from jkeating@redhat.com on 2010-05-03 22:54:49 EDT ---

Created an attachment (id=411171)
Attached traceback automatically from anaconda.

--- Additional comment from jkeating@redhat.com on 2010-05-03 22:57:45 EDT ---

I got this when going from a system with two md devices to a default partitioning.

Tossing on the blocker list for visibility.

--- Additional comment from jlaska@redhat.com on 2010-05-04 15:45:02 EDT ---

Same as bug#568759 ?

--- Additional comment from jkeating@redhat.com on 2010-05-04 17:00:20 EDT ---

Looks similar, but without knowing the root cause, hard to tell.  This may wind up being fixed by the other issue with md devices getting removed, so I'll wait until that bug is fixed and re-try.

--- Additional comment from awilliam@redhat.com on 2010-05-04 19:55:38 EDT ---

for me this is a blocker, per our criteria - any known fail at all when trying to set up a valid partition scheme counts as a blocker.

--- Additional comment from jkeating@redhat.com on 2010-05-05 14:17:22 EDT ---

Created an attachment (id=411701)
Attached traceback automatically from anaconda.

--- Additional comment from jkeating@redhat.com on 2010-05-05 14:18:31 EDT ---

Seems this is still happening with 13.40

--- Additional comment from jlaska@redhat.com on 2010-05-06 18:10:30 EDT ---

There is an updates.img available to work around this issue.  The updates.img should be applied to anaconda-13.40-1

http://dlehman.fedorapeople.org/updates-588597.img

--- Additional comment from jkeating@redhat.com on 2010-05-06 18:25:29 EDT ---

Makes it work here.

--- Additional comment from awilliam@redhat.com on 2010-05-06 22:24:37 EDT ---

that would make it fixed in 13.41, right?
Comment 2 RHEL Product and Program Management 2010-05-14 11:54:50 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 David Cantrell 2010-05-14 18:36:45 EDT
Can we get a qa_ack on this issue?  Issued discovered and fixed during F-13 development, affects RHEL-6.
Comment 6 Alexander Todorov 2010-07-21 12:07:43 EDT
(In reply to comment #0)
> --- Additional comment from jkeating@redhat.com on 2010-05-03 22:57:45 EDT ---
> 

The attached logs show that there were two raid arrays md0 and md1 mounted at /boot and /. 

I've tested with the -0721.n.0 nightly (which fixes bug #615936):

1st install was with 
/boot, md1 (vda1, vdb1) - RAID 1, ext4
/ md2 (vda2, vdb2) - RAID 1, ext4

2nd install I selected Remove existing Linux partitions and "review layout". Install completed without traceback creating LVM disk layout. Moving to VERIFIED.
Comment 7 releng-rhel@redhat.com 2010-11-10 14:43:43 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.