Bug 58868 - TGA2 graphics is not recognized correctly
TGA2 graphics is not recognized correctly
Status: CLOSED DUPLICATE of bug 58866
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Beth Uptagrafft
Beth Uptagrafft
Depends On:
  Show dependency treegraph
Reported: 2002-01-25 22:31 EST by harry.heinisch
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-30 22:19:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description harry.heinisch 2002-01-25 22:31:37 EST
Description of Problem: TGA2 graphics-based machines cannot do GUI install
as the card is not correctly recognized. In addition, the install does not
fail-over to text mode, forcing the user to enter text mode manually.

Version-Release number of selected component (if applicable): alpha-72-beta1

How Reproducible: Attempt to install via GUI on a TGA2-based machine.

Steps to Reproduce:

Actual Results: VGA16 server is started, but the screen is unusable. One can
exit the X server via Ctrl-Alt-Del, but the install then terminates abnormally.

Expected Results: Normal installation via GUI.

Additional Information: Text mode install works fine. X servers work fine
under normal operation after correct setup after the install.
Comment 1 Beth Uptagrafft 2002-02-04 15:11:17 EST
This system is outside the scope of the contract and will be marked CLOSED - 
Comment 2 Phil Copeland 2002-04-30 22:20:32 EDT
Fixed in final

No release not needed. Duplicate bug of 58866


*** This bug has been marked as a duplicate of 58866 ***
Comment 3 harry.heinisch 2002-05-07 10:55:24 EDT
Testing with the 0503.0 bits, this bug appears not to be fixed.

This bug is NOT really a duplicate of 58866; that one (TGA) fails because the
XF86Config-4 file is incomplete (needs a BusID). Installation on TGA does
go on successfully, as it fails-over correctly to text mode (I believe because
TGA does not identify itself as VGA-compatible in the PCI config info).

TGA-2 GUI install fails because it *does* identify itself as VGA-compatible,
leading anaconda to try the VGA-16 server, which works enough to trash the
screen and make it impossible to do anything but terminate the server, which
then (abnormally) terminates the install.

TGA gives a PCI CLASS of 0380, vendor/device IDs of 1011:0004.
TGA-2 gives PCI CLASS of 0300, vendor/device IDs of 1011:000d.

Note You need to log in before you can comment on or make changes to this bug.