Bug 588749 - Gallery installer fails at 'Step 8 - Install Gallery Core'
Gallery installer fails at 'Step 8 - Install Gallery Core'
Status: CLOSED DUPLICATE of bug 580236
Product: Fedora
Classification: Fedora
Component: gallery2 (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 08:47 EDT by steve
Modified: 2010-05-04 15:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 15:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gallery installer log (referenced in the error message) (2.91 KB, application/octet-stream)
2010-05-04 08:47 EDT, steve
no flags Details

  None (edit)
Description steve 2010-05-04 08:47:42 EDT
Created attachment 411277 [details]
gallery installer log (referenced in the error message)

Description of problem:
After installing gallery2-2.3.1-1.fc12 on my system, i tried configuring the gallery instance but it always fails on Step 8 ("Install Gallery Core")

Version-Release number of selected component (if applicable):
gallery2-2.3.1-1.fc12

How reproducible: Always

Steps to Reproduce:
1. Install gallery2 (yum install gallery2)
2. Read through /usr/share/gallery2/README.fedora for differences with upstream version of gallery
3. Start up httpd and point browser to 'http://localhost/gallery2/
4. Run through the installer. Note that Step 4 will complain:

Gallery file integrity -- Warning
Missing files (3)
=================
lib/smarty/COPYING.lib
lib/smarty/README
modules/core/classes/GalleryStorage/g2_db2.jar

Modified files (10)
===================
install/index.php
lib/smarty/Config_File.class.php
lib/smarty/Smarty.class.php
lib/smarty/Smarty_Compiler.class.php
lib/smarty/internals/core.write_cache_file.php
lib/smarty/plugins/function.fetch.php
lib/smarty/plugins/function.math.php
lib/smarty/plugins/modifier.debug_print_var.php
upgrade/index.php
modules/core/classes/GallerySession.class

5. Proceed anyways to Step 8, which will then complain:

=========================================================================

Core module is only partially installed.
Error installing Gallery Core

Something went wrong when we tried to install the core module. What to do next?

   1. Go to the System Checks step of the installer and make sure all checks shows 'Success'. A common issue is that the file integrity warning is ignored.
   2. If there are no warnings or failures in the System Checks step, empty your storage directory and delete the database tables and start the installation process a second time (redo all steps).
   3. Please visit the G2 FAQ and read the Known issues section of the Readme.
   4. If the problem persists, please copy the installation log which is located at /var/tmp/gallery2//install_984fda4f6c.log and attach it (as install.log.zip) to a new forum topic in the G2 support forum or, if possible, just add a link to the install.log in the forum topic such that the support staff can analyze it if necessary.
  
=========================================================================

Actual results:
- gallery2 installer gets stuck at Step 8

Expected results:

- Gallery2 installer should successfully proceed to Step 11 "Finish Installation"

Additional info:

I'm attaching the log file generated during the installation (referenced in the message above). Note, that i do not know much about gallery2 or about php. So all of this is missing/modified files bit is pretty confusing. I just want to install and use gallery.

Please let me know if you need any additional information.

cheers,
- steve
Comment 1 Remi Collet 2010-05-04 15:30:25 EDT
It seems this is linked to #580236
See https://admin.fedoraproject.org/updates/php-5.3.2-2.fc12

This Bug could probably be closed as duplicate
Comment 2 steve 2010-05-04 15:34:14 EDT
(In reply to comment #1)
> It seems this is linked to #580236
> See https://admin.fedoraproject.org/updates/php-5.3.2-2.fc12
> 
> This Bug could probably be closed as duplicate    

Yep ! Just tested it. I confirm that this can be closed as a duplicate.

cheers,
- steve

*** This bug has been marked as a duplicate of bug 580236 ***

Note You need to log in before you can comment on or make changes to this bug.