Bug 580236 - PHP update breaks gallery2 (and possibly other packages)
Summary: PHP update breaks gallery2 (and possibly other packages)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 578158 588749 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-07 19:35 UTC by Joshua Baker-LePain
Modified: 2010-05-15 20:44 UTC (History)
9 users (show)

Fixed In Version: maniadrive-1.2-21.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-06 03:36:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
PHP Bug Tracker 51624 None None None Never

Description Joshua Baker-LePain 2010-04-07 19:35:49 UTC
Description of problem:
After performing a recent yum update, my installation of gallery2 (from Fedora RPMs) stopped functioning -- all attempts to look at content were met with a blank page.  Some digging around showed multiple users having issues with php-5.3.2 on Fedora.  I did a 'yum downgrade php\*' and gallery2 started working again.

Version-Release number of selected component (if applicable):
php-5.3.2-1.fc12

How reproducible:
Completely.

Steps to Reproduce:
1. Install and configure gallery2, upgrade php to most recent version
2. Watch your gallery disappear.
3.
  
Actual results:
Blank pages when trying to access gallery content

Expected results:
Pictures!

Additional info:
This thread on the gallery forums <http://gallery.menalto.com/node/95244> shows multiple folks having the same issue, as well as at least one other affected project (Amahi).

Again, 'yum downgrade php\*' (which got me php-5.3.0-6.fc12 and related php subpackages) fixed the problem.  I'm on x86_64, if that matters.

Comment 1 Remi Collet 2010-04-09 06:19:48 UTC
I have reproduce the segfault with php 5.3.2 and latest snapshot (5.3.3-201004081030). Even with zend.enable_gc=Off.

I don't find any "open" upstream bug about this.

gallery2 is the only app I know with this issue.

Need more investigation and probably a simple reproduce script.

Comment 2 Göran Uddeborg 2010-04-12 19:31:44 UTC
My gallery2 installation has also stopped working.

In my case it is possible to see a public album.  But as soon as I try to log in, I get the blank page.  Is this the same problem as you have, or do you see a blank page even before trying to log in?

I tried to debug and tried

   $gallery->setDebug('buffered');

and

   $gallery->setDebug('logged');
   $gallery->setDebugLogFile('/srv/gallery2/debug.log')

in /etc/gallery2/config.php.  With either of these things start to work again!  I can log in and edit my albums.

Comment 3 Göran Uddeborg 2010-04-12 19:44:33 UTC
I have to take that partially back.  With debugging enabled, it SOMETIMES works.

Comment 4 Remi Collet 2010-04-13 17:58:49 UTC
*** Bug 578158 has been marked as a duplicate of this bug. ***

Comment 5 Felix Kaechele 2010-04-14 23:46:39 UTC
Upstream bug for Gallery2 is here: http://sourceforge.net/tracker/?func=detail&aid=2978414&group_id=7130&atid=107130

Comment 6 Felix Kaechele 2010-04-15 23:12:40 UTC
Some more interesting links regarding this bug:

http://gallery.menalto.com/node/95244
http://bugs.php.net/50519
http://bugs.php.net/50382

Workaround:

zend.enable_gc=Off in php.ini
or
php_value zend.enable_gc off in .htaccess

Confirmed working on my F13 install.

Comment 7 Remi Collet 2010-04-16 16:08:07 UTC
Program received signal SIGSEGV, Segmentation fault.
zval_mark_grey (pz=<value optimized out>) at /usr/src/debug/php-5.3.2/Zend/zend_gc.c:360
360				pz = *(zval**)p->pData;

Comment 8 Felix Kaechele 2010-04-16 19:44:25 UTC
There you go. That proves that it's the Zend Garbage Collector that is failing.

Comment 9 Göran Uddeborg 2010-04-25 21:40:15 UTC
I tried setting zend.enable_gc=Off in php.ini.  I still get a blank page when I try to log in.  I don't get any messages about segmentation faults in error_log, but the site still doesn't work.  This is with F12 httpd and php.

Comment 10 Remi Collet 2010-04-26 20:26:11 UTC
Bug seems fixed in 5.3.3-dev

I'm working on backporting some patches from SVN.

With 297307, 298253 (gc related) and 298253 (mysqli related) I don't encounter any segfault using gallery2 (installation, connection, adding elements, maintenance, ...)

I will try to push build ASAP.

+

Comment 11 Remi Collet 2010-04-27 16:13:18 UTC
Adding gallery2 maintainer in CC and take ownership.

Comment 12 Fedora Update System 2010-04-27 18:22:38 UTC
php-5.3.2-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/php-5.3.2-2.fc12

Comment 13 Fedora Update System 2010-04-28 22:43:18 UTC
php-5.3.2-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/php-5.3.2-2.fc12

Comment 14 Fedora Update System 2010-04-30 09:35:52 UTC
maniadrive-1.2-21.fc13,php-5.3.2-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/maniadrive-1.2-21.fc13,php-5.3.2-2.fc13

Comment 15 Fedora Update System 2010-04-30 23:45:58 UTC
maniadrive-1.2-21.fc13, php-5.3.2-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update maniadrive php'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/maniadrive-1.2-21.fc13,php-5.3.2-2.fc13

Comment 16 steve 2010-05-04 19:34:14 UTC
*** Bug 588749 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2010-05-06 03:36:20 UTC
php-5.3.2-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-05-15 20:44:14 UTC
maniadrive-1.2-21.fc13, php-5.3.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.