Bug 58878 - rsync segfaults
rsync segfaults
Status: CLOSED DUPLICATE of bug 58874
Product: Red Hat Linux
Classification: Retired
Component: rsync (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-26 06:11 EST by Gerald Teschl
Modified: 2014-03-16 22:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-29 07:16:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2002-01-26 06:11:02 EST
The latest rsync errata segfaults when using the -z option. Without
-z it spits out some warnings (the hdlist file is not the original one
from 7.2):

[root@soliton root]# rpm -q rsync
rsync-2.4.6-8
[root@soliton root]# rsync -v -v -aze ssh /usr/src/redhat-7.2/RedHat/base/
tomcat:/usr/src/redhat-7.2/RedHat/base/
building file list ... done
./
comps is uptodate
hdlist
Segmentation fault
[root@soliton root]# rsync -v -v -ae ssh /usr/src/redhat-7.2/RedHat/base/
tomcat:/usr/src/redhat-7.2/RedHat/base/
building file list ... done
./
comps is uptodate
hdlist
Warning: unexpected read size of 0 in map_ptr
Warning: unexpected read size of 0 in map_ptr
hdlist2
Warning: unexpected read size of 0 in map_ptr
Warning: unexpected read size of 0 in map_ptr
hdstg1.img is uptodate
netstg1.img is uptodate
stage2.img is uptodate
total: matches=7188  tag_hits=1454663  false_alarms=221 data=7704563
./
wrote 17741020 bytes  read 118516 bytes  463884.05 bytes/sec
total size is 80762845  speedup is 4.52
Comment 1 Bill Nottingham 2002-01-27 00:48:33 EST
Do you have a reliable case that reproduces this?
Comment 2 Bill Nottingham 2002-01-27 00:54:16 EST
Also, are the files that cause the warnings transferred correctly?
Comment 3 Gerald Teschl 2002-01-27 10:52:14 EST
I did some further testing and I can reproduce it:

[root@soliton tmp]# tar --use-compress-program bunzip2 -xf rsync.tar.bz2
[root@soliton tmp]# ls -lh local/hdlist2 remote/hdlist2
-rw-r--r--    1 root     root          15M Jan 26 12:02 local/hdlist2
-rw-r--r--    1 root     root          24M Jan 27 16:37 remote/hdlist2
[root@soliton tmp]# rsync -az local/ remote/
Segmentation fault
[root@soliton tmp]# ls -lh local/hdlist2 remote/hdlist2
-rw-r--r--    1 root     root          15M Jan 26 12:02 local/hdlist2
-rw-r--r--    1 root     root          24M Jan 27 16:37 remote/hdlist2
[root@soliton tmp]# rsync -a local/ remote/
Warning: unexpected read size of 0 in map_ptr
Warning: unexpected read size of 0 in map_ptr
[root@soliton tmp]# ls -lh local/hdlist2 remote/hdlist2
-rw-r--r--    1 root     root          15M Jan 26 12:02 local/hdlist2
-rw-r--r--    1 root     root          24M Jan 26 12:02 remote/hdlist2

The file rsync.tar.bz2 is 11MB. Shall I upload it to bugzilla or put
it on my ftp server so you can download it?
Comment 4 Bill Nottingham 2002-01-27 11:49:58 EST
Just as a test, if you rebuild rsync, does it start working for you?
Comment 5 Bill Nottingham 2002-01-27 12:13:04 EST
Please try:

http://people.redhat.com/notting/rsync-2.4.6-9.i386.rpm
Comment 6 Gerald Teschl 2002-01-27 17:09:32 EST
Yes, these packages seem to fix the problem. Thanks!
Comment 7 Need Real Name 2002-01-28 10:52:13 EST
Same issue here, rsync between redhat 7.2 and 7.0, both with the new errata.
Putting the 2.4.6-9 RPM referenced above onto the 7.2 box fixes the problem.
Comment 8 Need Real Name 2002-01-29 07:16:03 EST
Yes, I noticed this same problem on my system,
rsync arrived via up2date, and suddenly some of
by backup scripts stopped working.  Happy to
report that the above RPM solves my problem too.
Comment 9 Bill Nottingham 2002-01-29 10:42:15 EST

*** This bug has been marked as a duplicate of 58874 ***

Note You need to log in before you can comment on or make changes to this bug.