Bug 589230 - [NetworkManager][ALL_LANG] Translation updates
[NetworkManager][ALL_LANG] Translation updates
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
: Translation
: 627887 627914 (view as bug list)
Depends On:
Blocks: 575750
  Show dependency treegraph
 
Reported: 2010-05-05 11:49 EDT by Ankit Patel
Modified: 2011-05-19 10:24 EDT (History)
10 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-5.el6
Doc Type: Bug Fix
Doc Text:
Translations had assorted inconsistencies, including invalid characters as part of the network-manager-applet (languages: as, te, pa, gu, mr, fr, es, bn_IN) and NetworkManager (languages: bn_IN, es, fr, ja, mr). These are now fixed to display the correct translated strings.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:24:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Translation patch for NetworkManager/nm-applet for Red Hat Supported Languages (2.75 MB, patch)
2010-05-10 06:10 EDT, Ankit Patel
no flags Details | Diff
Translation patch 2 for NetworkManager/nm-applet for Red Hat Supported Languages (740.43 KB, patch)
2010-05-20 03:22 EDT, Ankit Patel
no flags Details | Diff
Translation patch 3 for NetworkManager for Red Hat supported languages (1.17 MB, patch)
2010-08-10 02:04 EDT, Ankit Patel
no flags Details | Diff
A patch to update translations of NetworkManager/nm-applet due to other bug fixes (1.05 MB, patch)
2011-03-15 07:40 EDT, Ankit Patel
no flags Details | Diff
A patch to update translations of NetworkManager/nm-applet due to other bug fixes (1.08 MB, patch)
2011-03-15 07:43 EDT, Ankit Patel
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0769 normal SHIPPED_LIVE NetworkManager bug fix and enhancement update 2011-05-18 14:08:36 EDT

  None (edit)
Description Ankit Patel 2010-05-05 11:49:00 EDT
Red Hat officially supports 22 languages, where translations is a major part. So, translations quality and completeness is required for all Tier1 components of RHEL6. NetworkManager is one of the localization Tier1 components that has to be localized in Red Hat supported Languages. This bug is to provide translation updates in terms of patches or tarball for totem for Red Hat supported languages.
Comment 2 RHEL Product and Program Management 2010-05-05 13:30:41 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Ankit Patel 2010-05-06 05:05:35 EDT
Since there were some updates in the translatable messages, we (Localization Team) needs to provide translation updates against those changes.
Comment 4 Ankit Patel 2010-05-10 06:10:12 EDT
Created attachment 412783 [details]
Translation patch for NetworkManager/nm-applet for Red Hat Supported Languages

Applying this patch should update Translations of Red Hat Supported Languages.
Comment 5 Dan Williams 2010-05-13 14:28:35 EDT
Hmm, it appears some translations don't have valid UTF-8.  For example, network-manager-applet/po/as.po near the text "The NetworkManager Applet could not find some required resources (the glade" fails UTF-8 validation.  ANy chance you could review and fix the issue?  YOu can check if the file is valid UTF-8 by doing:

iconv --from-code=UTF8 --to-code=UTF8 <patch file>

and if it fails with a message like "iconv: illegal input sequence at position 37896" then there are invalid characters where the output stopped.
Comment 6 Dan Williams 2010-05-13 14:36:06 EDT
Looks like the patch got line-wrapped badly somehow.
Comment 7 Dan Williams 2010-05-14 01:18:59 EDT
I managed to apply a number of the translations, but here are the ones I could not apply due to invalid characters or the fact that upstream changed and the translations given no longer applied:

network-manager-applet: as, te, pa, gu, mr, fr, es, bn_IN
NetworkManager: bn_IN, es, fr, ja, mr

If possible, could you get updated translations based of current RHEL nightly snapshots?  Thanks!
Comment 8 Ankit Patel 2010-05-18 08:39:10 EDT
(In reply to comment #7)
> I managed to apply a number of the translations, but here are the ones I could
> not apply due to invalid characters or the fact that upstream changed and the
> translations given no longer applied:
> 
> network-manager-applet: as, te, pa, gu, mr, fr, es, bn_IN
> NetworkManager: bn_IN, es, fr, ja, mr
> 
> If possible, could you get updated translations based of current RHEL nightly
> snapshots?  Thanks!    

Hi Dan,

I just found an update in network-manager-applet patch, because of which there are six new strings introduced. I will get it translated and make a new patch. However, I don't understand what's wrong with filetype. All PO files I have are "UTF-8 Unicode English Text" when I check the filetype with 'file' command.

/Ankit
Comment 9 Dan Williams 2010-05-20 02:51:04 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > I managed to apply a number of the translations, but here are the ones I could
> > not apply due to invalid characters or the fact that upstream changed and the
> > translations given no longer applied:
> > 
> > network-manager-applet: as, te, pa, gu, mr, fr, es, bn_IN
> > NetworkManager: bn_IN, es, fr, ja, mr
> > 
> > If possible, could you get updated translations based of current RHEL nightly
> > snapshots?  Thanks!    
> 
> Hi Dan,
> 
> I just found an update in network-manager-applet patch, because of which there
> are six new strings introduced. I will get it translated and make a new patch.
> However, I don't understand what's wrong with filetype. All PO files I have are
> "UTF-8 Unicode English Text" when I check the filetype with 'file' command.
> 
> /Ankit    

'file' doesn't check the entire file; there are invalid characters in the file as reported if you use the 'iconv' command to verify the entire file.  I see some updates have been committed upstream directly to network-manager-applet; but there are still some missing ones.  I have no idea how the translation patch got corrupted unfortunately, but it needs to be regenerated somehow.  If you get a new one I'm happy to commit the updates.  Thanks!
Comment 10 Ankit Patel 2010-05-20 03:22:00 EDT
Created attachment 415323 [details]
Translation patch 2 for NetworkManager/nm-applet for Red Hat Supported Languages

Hi,

Please check whether this patch works fine or not. I ran the 'iconv' check too.

Thanks!
Ankit
Comment 11 Dan Williams 2010-05-20 21:53:56 EDT
Turns out there were some weird errors in the upstream as.po which I corrected.  The rest of the translations applied perfectly.  Everything in the lastest patch is now upstream and should get down into RHEL quite soon.  Thanks!
Comment 14 Ankit Patel 2010-08-05 07:02:03 EDT
'make check' fails in PackageCVS, as well as there is no translation patch submitted in the CVS repo, hence status for RHEL6 supported languages shows incomplete.
Comment 16 Dan Williams 2010-08-09 14:28:25 EDT
(In reply to comment #14)
> 'make check' fails in PackageCVS, as well as there is no translation patch
> submitted in the CVS repo, hence status for RHEL6 supported languages shows
> incomplete.    

That's because as of the latest snapshot all translations were submitted upstream and our package builds include them.  Thus no patch is needed.  If there additional translation updates required for RHEL6 then we should:

1) generate a new .po and submit it upstream to gnome.org bugzilla so the upstream localization teams can review and approve

2) in the interim I'll take that .po file and make it a local patch

Please let me know soon if additional translation updates are required for RHEL6 beyond what's already built in NetworkManager-0.8.1-4.el6.
Comment 17 Ankit Patel 2010-08-10 01:58:24 EDT
(In reply to comment #16)
> (In reply to comment #14)
> > 'make check' fails in PackageCVS, as well as there is no translation patch
> > submitted in the CVS repo, hence status for RHEL6 supported languages shows
> > incomplete.    
> 
> That's because as of the latest snapshot all translations were submitted
> upstream and our package builds include them.  Thus no patch is needed.  If
> there additional translation updates required for RHEL6 then we should:
> 
> 1) generate a new .po and submit it upstream to gnome.org bugzilla so the
> upstream localization teams can review and approve

Why can't we have rhel6 internal only patch? (just like the other patches)

Basically, we have Indic translators working along with Gnome upstream community but rest of the translators are not at all working with Gnome upstream, hence thy can't submit the translations to upstream!

> 
> 2) in the interim I'll take that .po file and make it a local patch
> 
> Please let me know soon if additional translation updates are required for
> RHEL6 beyond what's already built in NetworkManager-0.8.1-4.el6.    

There are some po files which are not showing complete for Red Hat supported languages. So, yes, we need to submit a patch downstream (rhel6) only.

Thanks!
Ankit
Comment 18 Ankit Patel 2010-08-10 02:04:20 EDT
Created attachment 437777 [details]
Translation patch 3 for NetworkManager for Red Hat supported languages

Applying this patch overwriting earlier one should update translations for all Red Hat Supported languages (except Assamese [as.po], due to no resource).

Thanks!
Ankit
Comment 19 Dan Williams 2010-08-10 11:52:00 EDT
(In reply to comment #17)
> (In reply to comment #16)
> > (In reply to comment #14)
> > > 'make check' fails in PackageCVS, as well as there is no translation patch
> > > submitted in the CVS repo, hence status for RHEL6 supported languages shows
> > > incomplete.    
> > 
> > That's because as of the latest snapshot all translations were submitted
> > upstream and our package builds include them.  Thus no patch is needed.  If
> > there additional translation updates required for RHEL6 then we should:
> > 
> > 1) generate a new .po and submit it upstream to gnome.org bugzilla so the
> > upstream localization teams can review and approve
> 
> Why can't we have rhel6 internal only patch? (just like the other patches)

We can, and we'll apply that.  But we *also* need to push any translation fixes that we have upstream as well so that we're not carrying un-necessary patches in our local trees.  It's also just good citizenship; we benefit hugely from upstream translations, and by the same token we should contribute our translations upstream too.

> Basically, we have Indic translators working along with Gnome upstream
> community but rest of the translators are not at all working with Gnome
> upstream, hence thy can't submit the translations to upstream!

It's actually not that hard; you just create a new bug on http://bugzilla.gnome.org and attach your corrected .po file.  Then the upstream translation teams will review it, and I'll be able to commit it to source control.

> > 
> > 2) in the interim I'll take that .po file and make it a local patch
> > 
> > Please let me know soon if additional translation updates are required for
> > RHEL6 beyond what's already built in NetworkManager-0.8.1-4.el6.    
> 
> There are some po files which are not showing complete for Red Hat supported
> languages. So, yes, we need to submit a patch downstream (rhel6) only.

And that's fine.  But we should also be pushing them upstream.

HOwever, I notice that the attached .po file has updates for *many* translations, not just the 3 you reference.  And some of those changes are not actually changes, like in de.po:

-msgid "Set to TRUE to disable creation of adhoc networks when using the applet."
+msgid ""
+"Set to TRUE to disable creation of adhoc networks when using the applet."

which make the patch a lot bigger than it needs to be...  which specific translations are not showing complete so I can reduce the patch to only those translations?

Thanks!
Comment 21 Dan Williams 2010-08-10 14:04:10 EDT
I did just commit ID and OR translations that came in upstream overnight...

However, is there some way I can get a list of the translations that are not at 100% so that I can just apply the patch for those languages, and not all the rest that dont' have any material changes?
Comment 22 Ankit Patel 2010-08-10 14:24:38 EDT
(In reply to comment #21)
> I did just commit ID and OR translations that came in upstream overnight...
> 
> However, is there some way I can get a list of the translations that are not at
> 100% so that I can just apply the patch for those languages, and not all the
> rest that dont' have any material changes?    

Hi Dan,

I can see NetworkManager (and NM/network-manager-applet both) has all Red Hat Supported languages 100% without the patch, but if you look at the number of messages closely, they differ from the ones I have submitted.

Basically, I have created and up2date POT file using "intltool-update -P" command from the po directory after 'make check' in PackageCVS (RH-CVS) and then merged the output POT file with the translations available from PackageCVS and got it translated.

So, you might notice msgids also added and removed in this patch.

I think you might want to apply the patch entirely.

Thanks!
Ankit
Comment 23 Dan Williams 2010-08-10 14:37:46 EDT
Is there any way for example to get the tools to *not* re-linebreak stuff by allowing existing strings that are over 80-chars wide to stay that way?  That would go a long way to cleaning out some of the unecessary stuff in the patch.
Comment 37 A S Alam 2010-08-15 13:46:02 EDT
status - FAILED
Tested Package: NetworkManager-0.8.1-5.el6.x86_64

MO status - (two MO files by NetworkManager)
1) nm-applet.mo - Not 100% (Different/Unequal Number of Strings)

nm-applet
as:
496 translated messages.
bn_IN:
500 translated messages.
de:
499 translated messages.
es:
499 translated messages.
fr:
499 translated messages.
gu:
499 translated messages.
hi:
492 translated messages.
it:
500 translated messages.
ja:
500 translated messages.
kn:
501 translated messages.
ko:
501 translated messages.
mr:
499 translated messages.
ml:
501 translated messages.
or:
501 translated messages.
pa:
499 translated messages.
pt_BR:
501 translated messages.
ru:
500 translated messages.
ta:
501 translated messages.
te:
499 translated messages.
zh_CN:
499 translated messages.
zh_TW:
501 translated messages.


2) NetworkManager.mo - as.po/pa.po
---
as:
313 translated messages.
bn_IN:
327 translated messages.
de:
327 translated messages.
es:
327 translated messages.
fr:
327 translated messages.
gu:
327 translated messages.
hi:
327 translated messages.
it:
327 translated messages.
ja:
327 translated messages.
kn:
327 translated messages.
ko:
327 translated messages.
mr:
327 translated messages.
ml:
327 translated messages.
or:
327 translated messages.
pa:
313 translated messages.
pt_BR:
327 translated messages.
ru:
327 translated messages.
ta:
327 translated messages.
te:
327 translated messages.
zh_CN:
327 translated messages.
zh_TW:
327 translated messages.
-----
Comment 38 Ankit Patel 2010-08-16 01:22:12 EDT
(In reply to comment #37)
> status - FAILED
> Tested Package: NetworkManager-0.8.1-5.el6.x86_64
> 
> MO status - (two MO files by NetworkManager)
> 1) nm-applet.mo - Not 100% (Different/Unequal Number of Strings)
> 
> nm-applet
> as:
> 496 translated messages.
> bn_IN:
> 500 translated messages.
> de:
> 499 translated messages.
> es:
> 499 translated messages.
> fr:
> 499 translated messages.
> gu:
> 499 translated messages.
> hi:
> 492 translated messages.
> it:
> 500 translated messages.
> ja:
> 500 translated messages.
> kn:
> 501 translated messages.
> ko:
> 501 translated messages.
> mr:
> 499 translated messages.
> ml:
> 501 translated messages.
> or:
> 501 translated messages.
> pa:
> 499 translated messages.
> pt_BR:
> 501 translated messages.
> ru:
> 500 translated messages.
> ta:
> 501 translated messages.
> te:
> 499 translated messages.
> zh_CN:
> 499 translated messages.
> zh_TW:
> 501 translated messages.
> 
> 
> 2) NetworkManager.mo - as.po/pa.po
> ---
> as:
> 313 translated messages.
> bn_IN:
> 327 translated messages.
> de:
> 327 translated messages.
> es:
> 327 translated messages.
> fr:
> 327 translated messages.
> gu:
> 327 translated messages.
> hi:
> 327 translated messages.
> it:
> 327 translated messages.
> ja:
> 327 translated messages.
> kn:
> 327 translated messages.
> ko:
> 327 translated messages.
> mr:
> 327 translated messages.
> ml:
> 327 translated messages.
> or:
> 327 translated messages.
> pa:
> 313 translated messages.
> pt_BR:
> 327 translated messages.
> ru:
> 327 translated messages.
> ta:
> 327 translated messages.
> te:
> 327 translated messages.
> zh_CN:
> 327 translated messages.
> zh_TW:
> 327 translated messages.
> -----

The patch I submitted should have got everything 100%, but since it's tweaked before applying, this change in status has been introduced.

Btw, from the below status, as well as my verification from DistCVS,

1) NetworkManager/hi.po, nm-applet/pa.po looks a problem to me, rest all are fine.

2) */as.po is expected because of incomplete translations due to no resource, which will be taken in 6.1.

Thanks!
Ankit
Comment 39 Dan Williams 2010-08-24 11:24:08 EDT
I've fixed upstream NM hi.po:

3f2e933f244df404e732b3b7b15f70c68a98d3ae (master)
01193d598c1c30d2fbf30719bd345f9720afcdaa (0.8.x)

since the only people that have touched the Hindi translation are Red Hat contributors, and since the only approved committed for the upstream GNOME Hindi team is Rajesh Ranjan, I don't think upstream translators will care that I've committed the upstream translation.
Comment 40 Dan Williams 2010-08-24 11:26:30 EDT
Upstream also pushed a translation update for the applet's pa.po:

commit 0ae71d0fccdb033652e640df7079d4a699e3bea7
Author: A S Alam <aalam@users.sf.net>
Date:   Mon Aug 16 07:57:09 2010 +0530

so we could also suck down that specific po file as well, given that it's already committed upstream.

I'm happy to include these two fixes (applet pa.po, NM hi.po) in the next snapshot if PM agrees.
Comment 42 A S Alam 2010-09-01 01:03:39 EDT
*** Bug 627914 has been marked as a duplicate of this bug. ***
Comment 43 A S Alam 2010-09-01 01:04:48 EDT
from Bug #627914
----
The words "routes" are not translated into Chinese in "Editing DSL connection"
screen.
----
Comment 45 Suzanne Yeghiayan 2010-09-20 15:31:56 EDT
*** Bug 627887 has been marked as a duplicate of this bug. ***
Comment 46 Dan Williams 2010-09-28 16:00:18 EDT
Brew build with the updated Punjabi translation:

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2785531
Comment 51 Ankit Patel 2011-03-15 07:40:28 EDT
Created attachment 484440 [details]
A patch to update translations of NetworkManager/nm-applet due to other bug fixes

Hi,

This patch will fix the remaining bits of translations mentioned in comment #49. Please have it also included in the next build along with previous patches.

Thank You!
Ankit Patel
Comment 52 Ankit Patel 2011-03-15 07:41:07 EDT
Re-assigning bug back to the owner of the component, as translations are submitted in terms of patches.
Comment 53 Ankit Patel 2011-03-15 07:43:51 EDT
Created attachment 484443 [details]
A patch to update translations of NetworkManager/nm-applet due to other bug fixes

Replacing older one, as there was Punjabi missing in the first patch.
Comment 58 Jirka Klimes 2011-04-05 08:19:34 EDT
Ankit,
is it possible to include a patch with *only* relevant changes? That is, just real string changes.
It is very hard to proceed with 1MB+ patch with many irrelevant changes (like line changes in comments, line breaks changes, etc.)

Best, please could you make patch for only necessary changes against to NetworkManager-0.8.1-7.el6, so that we can update patches we now have in RHEL (basically they are patches from #comments 31 and 32).
Thanks.
Comment 60 Ankit Patel 2011-04-06 02:24:10 EDT
(In reply to comment #58)
> Ankit,
> is it possible to include a patch with *only* relevant changes? That is, just
> real string changes.
> It is very hard to proceed with 1MB+ patch with many irrelevant changes (like
> line changes in comments, line breaks changes, etc.)
> 
> Best, please could you make patch for only necessary changes against to
> NetworkManager-0.8.1-7.el6, so that we can update patches we now have in RHEL
> (basically they are patches from #comments 31 and 32).
> Thanks.

Dear Jirka,

It's neither possible editing patch manually by hand nor advisable as translators do put their comments in-line for their translation context reference.

/Ankit
Comment 63 Ankit Patel 2011-04-07 06:29:50 EDT
I did check the latest build and everything looks perfect now, except Hindi (hi.po) file for network-manager-applet showing 1 Fuzzy which is actually correct translation. Probably because of manual editing of patch would have brought it. But that's fine as it's not an major issue.

Thanks!
Ankit
Comment 65 Misha H. Ali 2011-04-20 02:45:54 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Translations had assorted inconsistencies, including invalid characters as part of the network-manager-applet (languages: as, te, pa, gu, mr, fr, es, bn_IN) and NetworkManager (languages: bn_IN, es, fr, ja, mr). These are now fixed to display the correct translated strings.
Comment 66 errata-xmlrpc 2011-05-19 10:24:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0769.html

Note You need to log in before you can comment on or make changes to this bug.