Bug 589303 - RHEL 6 i386 installation hangs on Dell Optiplex 740
RHEL 6 i386 installation hangs on Dell Optiplex 740
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Charles Rose (RH)
Red Hat Kernel QE team
:
Depends On:
Blocks: 846704
  Show dependency treegraph
 
Reported: 2010-05-05 15:26 EDT by Gary Gatling
Modified: 2014-01-23 16:41 EST (History)
4 users (show)

See Also:
Fixed In Version: 6.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 16:41:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport report file (502.04 KB, application/x-xz)
2010-07-07 16:10 EDT, Gary Gatling
no flags Details
serial console log (3.69 KB, text/plain)
2011-03-09 14:50 EST, Gary Gatling
no flags Details

  None (edit)
Description Gary Gatling 2010-05-05 15:26:32 EDT
Description of problem:


An attempt to install RHEL 6 beta 1 using the i386 DVD fails when the installation hangs after the Probing EDD step on a DELL Optiplex 740 at latest BIOS revision.

initrd.img loads OK and says ready. The EDD probe apparently succeeds in that
it says ok, but then the installation hangs with no response to the keyboard
and no further output. It still hangs with edd=off. 

The only way I was able to install was to use the argument:

mem=4294967296

as argument at install time. (I have 4 GB or RAM)


Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Load i386 RHEL 6 beta 1 DVD
2. Boot machine
3. Select install or upgrade

Actual results:
Installation hangs.

Expected results:
Should install without needing mem= argument.

Additional info:
Comment 1 Gary Gatling 2010-05-05 15:28:05 EDT
This seems to be similar or the same as bug 538911 in fedora 12.
Comment 3 RHEL Product and Program Management 2010-05-05 17:07:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Gary Gatling 2010-07-07 14:45:53 EDT
This is still a problem with RHEL 6, beta 2 DVD. The error message I am seeing with RHEL 6 beta 2 DVD is:

(lots of dots)
Not enough memory to load specified image.

giving mem=4294967296 as a kernel argument still works around the problem.

This is a problem on the DELL Optiplex 740 workstation with RHEL 6 64 bit workstation / Client beta 2 DVD.
Comment 5 Shyam Iyer 2010-07-07 14:57:19 EDT
Can you attach a sosreport log to this BZ ?
Comment 6 Gary Gatling 2010-07-07 16:10:32 EDT
Created attachment 430170 [details]
sosreport report file

Here is the sosreport report file from a Optiplex 740 workstation. It was
installed with RHEL 6 beta 2 DVD. It seems to happen with 32 bit or 64 bit install. This report ran on a 64 bit install. In order to install I had to use the mem=4294967296 as a kernel argument.
Comment 7 RHEL Product and Program Management 2010-07-15 10:21:26 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 8 Shyam Iyer 2010-12-16 21:05:01 EST
(In reply to comment #6)
> Created attachment 430170 [details]
> sosreport report file
> 
> Here is the sosreport report file from a Optiplex 740 workstation. It was
> installed with RHEL 6 beta 2 DVD. It seems to happen with 32 bit or 64 bit
> install. This report ran on a 64 bit install. In order to install I had to use
> the mem=4294967296 as a kernel argument.

Gary,

Are you still available to help on this issue.
If yes, would love a serial console log from the sytem. (If that is possible)

-Shyam
Comment 9 Gary Gatling 2010-12-17 13:51:22 EST
Hello,

Thanks for checking on this...

I don't think its a problem with the final RHEL 6 release. I have done some installs with the Optiplex 740 with RHEL 6.0 final and it works ok. I didn't have to enter any special kernel options.

Cheers,
Comment 10 Gary Gatling 2011-02-10 10:54:21 EST
Sorry. I was wrong. This is still a problem. It turns out there is a "Optiplex 740" and a "Optiplex 740 Enhanced." I only had access in my building to a "Optiplex 740 Enhanced." But the problem is still happening on a "Optiplex 740" with the Red Hat Enterprise 6.0 install DVD. Adding the mem=4294967296 as arguments in anaconda still works as a workaround for me. (Machine has 4 GB)
Comment 11 Gary Gatling 2011-02-10 11:11:45 EST
The computer is connected to a monitor and keyboard / mouse (USB) so I'm not sure how to attach a serial console log from the system. can you explain what I need to do? I can try to create it.
Comment 12 Gary Gatling 2011-02-19 16:03:44 EST
Ok. I ordered a serial null cable online and I have the cable. What do I need to do to get the info you need to fix this? I tried opening "minicom" on another linux computer and I added "serial" to the boot options in the boot DVD for RHEL 6 but it does not appear to divert the "dots" to go to the serial port. (At least from what I can see within minicom on computer #2)

Is there some howto or instructions on how to create a serial console log? Do I need further arguments on the kernel options after pressing "tab" ?

Thanks,
Comment 13 Shyam Iyer 2011-02-28 12:49:36 EST
(In reply to comment #12)
> Ok. I ordered a serial null cable online and I have the cable. What do I need
> to do to get the info you need to fix this? I tried opening "minicom" on
> another linux computer and I added "serial" to the boot options in the boot DVD
> for RHEL 6 but it does not appear to divert the "dots" to go to the serial
> port. (At least from what I can see within minicom on computer #2)
> 
> Is there some howto or instructions on how to create a serial console log? Do I
> need further arguments on the kernel options after pressing "tab" ?
> 
> Thanks,

Add to the Server kernel command line :
"console=tty0 console=ttyS0,115200,8n1"

The catcher i.e. the other end of the null modem cable you could configure minicom to open /dev/ttyS0 with the same baudrate settings.

-Shyam
Comment 14 Gary Gatling 2011-03-09 14:50:12 EST
Created attachment 483295 [details]
serial console log
Comment 15 Gary Gatling 2011-03-09 14:56:36 EST
I tried to do as suggested but it did not work.

Here is what I did.

I inserted a Red Hat Enterprise Linux 6 DVD and booted off of it.

I pressed "tab" when the SYSLINUX GUI came up.

I appended to the end of the arguments console=tty0 console=ttyS0,115200,8n1

and then pressed "Enter" but the dots still go to the VGA screen!

So I went ahead and installed the machine with mem=XXXXX and text keywords
and then I edited the GRUB menu at bootup and added to the kernel lines:

console=tty0 console=ttyS0,115200,8n1

and this did generate output in minicomm but I'm guessing this isn't what
you were looking for, correct? (because at this point the OS has been installed with workarounds)

If someone can tell me how to do this off the DVD boot media rather than the hard disk I can try to provide the info you wanted. However if this is what was asked for then I guess this will help?
Comment 16 RHEL Product and Program Management 2011-10-07 11:01:46 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 17 Gary Gatling 2012-09-18 14:41:45 EDT
Looks like this got fixed in RHEL 6.3 install media. Thanks!
Comment 18 Charles Rose 2014-01-23 16:41:14 EST
(In reply to Gary Gatling from comment #17)
> Looks like this got fixed in RHEL 6.3 install media. Thanks!

Closing.

Note You need to log in before you can comment on or make changes to this bug.