Bug 589470 - Whole X window froze
Summary: Whole X window froze
Status: CLOSED DUPLICATE of bug 568780
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard: card_945GM
Keywords: Reopened, Triaged
: 592434 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 08:58 UTC by Martin Stransky
Modified: 2010-07-21 00:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 00:44:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log (69.17 KB, text/plain)
2010-05-06 08:58 UTC, Martin Stransky
no flags Details
Xorg.log after crash (62.59 KB, text/plain)
2010-05-07 11:53 UTC, Martin Stransky
no flags Details
crash log from today (75.01 KB, text/plain)
2010-06-15 10:26 UTC, Martin Stransky
no flags Details
error state (757.15 KB, text/plain)
2010-07-14 09:18 UTC, Martin Stransky
no flags Details
messages (261.51 KB, text/plain)
2010-07-14 09:18 UTC, Martin Stransky
no flags Details
state log 2 (756.83 KB, text/plain)
2010-07-14 13:24 UTC, Martin Stransky
no flags Details
messages from screen flashing (107.42 KB, text/plain)
2010-07-15 08:51 UTC, Martin Stransky
no flags Details
Xorg.log from flashing (40.99 KB, text/plain)
2010-07-15 08:52 UTC, Martin Stransky
no flags Details
Xorg.log.old from flashing (49.23 KB, text/plain)
2010-07-15 08:52 UTC, Martin Stransky
no flags Details

Description Martin Stransky 2010-05-06 08:58:01 UTC
Created attachment 411884 [details]
dmesg log

Description of problem:

During normal web browsing, whole X session was frozen, no kb/mouse input, switch to text console works. There is not any info about the crash in Xorg.log(old)/messages, only in dmesg.

HW is LenovoT60/Intel:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Comment 2 RHEL Product and Program Management 2010-05-06 10:45:49 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Martin Stransky 2010-05-07 11:49:28 UTC
It happens 2-3 times in hour and it's not related to Firefox - the same crash happened when I browsed a document in evince.

Comment 4 Martin Stransky 2010-05-07 11:53:04 UTC
Created attachment 412314 [details]
Xorg.log after crash

Comment 5 Martin Stransky 2010-05-10 14:30:49 UTC
Is there any extra info I can provide? I didn't see the bug before I moved my production box to RHEL6, everything works fine on Fedora 12.

Comment 6 Lubos Kocman 2010-05-20 20:10:35 UTC
*** Bug 592434 has been marked as a duplicate of this bug. ***

Comment 7 Lubos Kocman 2010-05-20 20:15:12 UTC
I'm having the same problems as descripted in https://bugzilla.redhat.com/show_bug.cgi?id=592434. But I'm able to switch to the console using ctrl+alt+f#.

Comment 9 Dave Airlie 2010-05-31 02:08:33 UTC
still a problem original reporter?

Comment 10 Martin Stransky 2010-06-15 10:26:53 UTC
Created attachment 424099 [details]
crash log from today

Yes, I can still reproduce it although not every day.

Comment 11 Adam Jackson 2010-06-16 18:45:36 UTC
When this happens, please do:

# mount -t debugfs debugfs /sys/kernel/debug
# cat /sys/kernel/debug/dri/0/i915/i915_error_state > /tmp/i915_error_state

and attach the resulting error state file to this bug.

Comment 12 Lubos Kocman 2010-06-17 06:38:58 UTC
Hello,

I'm unable to reproduce this any more (Thinkpad T400 / x86_64)

Comment 13 Adam Jackson 2010-06-23 16:33:35 UTC
Lubos, what kernel are you running now?

Comment 14 Adam Jackson 2010-06-24 17:28:37 UTC
Removing from blocker list for comment #12.  Martin, please re-set blocker? if you are still seeing this.

Comment 15 Martin Stransky 2010-06-24 19:15:23 UTC
I haven't reproduced it since the last crash I posted here. Will update the bug when it happens again.

Comment 16 Lubos Kocman 2010-06-25 08:16:10 UTC
Hello,

I'm not able to reproduce this on my desktop with:

kernel-2.6.32-37.el6.x86_64
xorg-x11-server-Xorg-1.7.7-12.el6.x86_64
xorg-x11-server-common-1.7.7-12.el6.x86_64
xorg-x11-server-utils-7.4-15.el6.x86_64
xorg-x11-drv-intel-2.11.0-5.el6.x86_64

But Xorg behaves similar during RHEL6.0 installation. May this be somehow connected to #603003?

Can anybody who suffered from this try to reproduce #603003 (Switch from Xorg to Console and back (during latest RHEL 6.0  installation)?

Comment 17 Adam Jackson 2010-06-25 19:26:29 UTC
This and bug #603003 are almost certainly not the same issue.  Even if they are, let's treat them separately instead of confusing them.

Comment 18 Adam Jackson 2010-06-28 19:42:35 UTC
Comment #15 and comment #16 sound like _this_ issue is resolved.  603003 might not be, but let's follow up on that there.

Comment 19 Martin Stransky 2010-07-14 09:18:13 UTC
Created attachment 431718 [details]
error state

Comment 20 Martin Stransky 2010-07-14 09:18:47 UTC
Created attachment 431719 [details]
messages

Comment 21 Martin Stransky 2010-07-14 09:20:37 UTC
It happened today again (I updated my system yesterday).

Comment 22 Martin Stransky 2010-07-14 13:24:47 UTC
Created attachment 431770 [details]
state log 2

X crashed again, second log. It usually happens when I'm scrolling a page in Firefox or pdf reader (evince).

Comment 23 Adam Jackson 2010-07-14 16:36:24 UTC
Well at least those two error state files are consistent.  They both decode to something like:

batchbuffer at 0x0df82000:
0x0df82000:      0x54f00006: XY_SRC_COPY_BLT (rgb enabled, alpha enabled, src tile 0, dst tile 0)
0x0df82004:      0x03cc2000:    format 8888, dst pitch 8192, clipping disabled
0x0df82008:      0x00750000:    dst (0,117)
0x0df8200c:      0x039b04f1:    dst (1265,923)
0x0df82010:      0x06000000:    dst offset 0x06000000
0x0df82014:      0x00810000:    src (0,129)
0x0df82018:      0x00002000:    src pitch 8192
0x0df8201c:      0x06000000:    src offset 0x06000000
0x0df82020:      0x54300004: XY_COLOR_BLT (rgb enabled, alpha enabled, dst tile 0)
0x0df82024:      0x03f02000:    format 8888, pitch 8192, clipping disabled
0x0df82028:      0x00000000:    (0,0)
0x0df8202c:      0x03230500:    (1280,803)
0x0df82030:      0x0e000000:    offset 0x0e000000
0x0df82034:      0xffffffff:    color
0x0df82038:      0x54300004: XY_COLOR_BLT (rgb enabled, alpha enabled, dst tile 0)
0x0df8203c:      0x03f02000:    format 8888, pitch 8192, clipping disabled
0x0df82040:      0x000004f1:    (1265,0)
0x0df82044:      0x03140500:    (1280,788)
0x0df82048:      0x0e000000:    offset 0x0e000000
0x0df8204c:      0xffd7d5d3:    color
0x0df82050:      0x54300004: XY_COLOR_BLT (rgb enabled, alpha enabled, dst tile 0)
0x0df82054:      0x03f02000:    format 8888, pitch 8192, clipping disabled
0x0df82058:      0x000004f2:    (1266,0)
0x0df8205c:      0x031404ff:    (1279,788)
0x0df82060:      0x0e000000:    offset 0x0e000000
0x0df82064:      0xffd6d4d2:    color
0x0df82068:      0x66014140: 3DSTATE_ANTI_ALIASING
0x0df8206c: HEAD 0x6ba008a1: 3DSTATE_INDEPENDENT_ALPHA_BLEND
0x0df82070:      0x7d990000: 3DSTATE_DEFAULT_DIFFUSE
0x0df82074:      0x00000000:    dword 1
0x0df82078:      0x7d9a0000: 3DSTATE_DEFAULT_SPECULAR
0x0df8207c:      0x00000000:    dword 1
0x0df82080:      0x7d980000: 3DSTATE_DEFAULT_Z
0x0df82084:      0x00000000:    dword 1
0x0df82088:      0x76fac688: 3DSTATE_COORD_SET_BINDINGS
0x0df8208c:      0x6700a770: 3DSTATE_RASTERIZATION_RULES
0x0df82090:      0x6db3ffff: 3DSTATE_MODES_4
0x0df82094:      0x7d040080: 3DSTATE_LOAD_STATE_IMMEDIATE_1
0x0df82098:      0x00000000:    S3
0x0df8209c:      0x7c800002: 3DSTATE_SCISSOR_ENABLE
0x0df820a0:      0x7d810001: 3DSTATE_SCISSOR_RECTANGLE
0x0df820a4:      0x00000000:    dword 1
0x0df820a8:      0x00000000:    dword 2
0x0df820ac:      0x7c880002: 3DSTATE_DEPTH_SUBRECTANGLE_DISABLE
0x0df820b0:      0x7d070000: 3DSTATE_LOAD_INDIRECT
0x0df820b4:      0x00000000: MI_NOOP
0x0df820b8:      0x7d830000: 3DSTATE_SPAN_STIPPLE
0x0df820bc:      0x00000000:    dword 1
0x0df820c0:      0x68000002: 3DSTATE_BACKFACE_STENCIL_OPS
0x0df820c4:      0x00000000: MI_NOOP

The HEAD pointer is consistently stalled at the INDEPENDENT_ALPHA_BLEND op.  I'm guessing that there's some hardware errata that means you can't change that bit of 3D state while some 3D processing is active.

Comment 24 Adam Jackson 2010-07-14 18:42:16 UTC
Martin, can you try this build and report

a) whether it's noticeably slower
b) whether you can still reproduce the lockups

http://download.devel.redhat.com/brewroot/scratch/ajackson/task_2597465/

Comment 25 Martin Stransky 2010-07-14 19:21:53 UTC
Okay, I'll try it tomorrow. But the graphics looks pretty slow already, in some moments (repainting whole screen for example) looks like a VESA driver instead of accelerated one. It's definitely worse user experience than I have with Fedora 12.

Comment 26 Martin Stransky 2010-07-15 08:49:26 UTC
With the packages from http://download.devel.redhat.com/brewroot/scratch/ajackson/task_2597465/ X window does not start. It keeps flashing and turning monitor on and off.

Comment 27 Martin Stransky 2010-07-15 08:51:59 UTC
Created attachment 432003 [details]
messages from screen flashing

Comment 28 Martin Stransky 2010-07-15 08:52:31 UTC
Created attachment 432004 [details]
Xorg.log from flashing

Comment 29 Martin Stransky 2010-07-15 08:52:55 UTC
Created attachment 432005 [details]
Xorg.log.old from flashing

Comment 30 Dave Airlie 2010-07-19 05:40:49 UTC
https://brewweb.devel.redhat.com/taskinfo?taskID=2606300

does the build from here help any? it might be a bit chatty in the logs.

Comment 31 Martin Stransky 2010-07-19 07:09:40 UTC
I reinstalled my box completelly and with xorg-x11-drv-intel-2.11.0-6.el6.i686 and no crashes so far. Will check your new package.

Comment 32 Martin Stransky 2010-07-19 07:27:25 UTC
With packages from https://brewweb.devel.redhat.com/taskinfo?taskID=2606300 it freezes after login do gdm. All logs (X, X.old, messages) are clear...

Comment 33 Martin Stransky 2010-07-19 13:12:15 UTC
btw. I can reproduce the same bug on rawhide (on the same box).

Comment 34 Dave Airlie 2010-07-20 03:55:59 UTC
okay 

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2609115

when finished will end up at


http://download.devel.redhat.com/brewroot/scratch/airlied/task_2609115

can you guys install that kernel on a clean EL6 and see does it enhance your experience?

Comment 35 Dave Airlie 2010-07-21 00:44:49 UTC
closing this as a duplicate of the other 945GM bug which has flags.

*** This bug has been marked as a duplicate of bug 568780 ***


Note You need to log in before you can comment on or make changes to this bug.