Bug 589498 - [abrt] crash in yum-utils-1.1.26-1.fc13: yumRepo.py:423:check:RepoError: Cannot find a valid baseurl for repo: rpmfusion-nonfree-updates
[abrt] crash in yum-utils-1.1.26-1.fc13: yumRepo.py:423:check:RepoError: Cann...
Status: CLOSED DUPLICATE of bug 582039
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:549726dc
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 06:27 EDT by Mads Kiilerich
Modified: 2014-01-21 18:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 12:21:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2010-05-06 06:27:11 EDT
abrt 1.1.0 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/package-cleanup --orphans
comment: I would expect an error message, not a stacktrace
component: yum-utils
executable: /usr/bin/package-cleanup
kernel: 2.6.33.3-72.fc13.i686.PAE
package: yum-utils-1.1.26-1.fc13
reason: yumRepo.py:423:check:RepoError: Cannot find a valid baseurl for repo: rpmfusion-nonfree-updates
release: Fedora release 13 (Goddard)

backtrace
-----
yumRepo.py:423:check:RepoError: Cannot find a valid baseurl for repo: rpmfusion-nonfree-updates

Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 384, in <module>
    util = PackageCleanup()
  File "/usr/bin/package-cleanup", line 59, in __init__
    self.main()
  File "/usr/bin/package-cleanup", line 362, in main
    for po in sorted(self.doPackageLists(pkgnarrow='extras').extras):
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1971, in doPackageLists
    avail = self.pkgSack.simplePkgList(patterns=patterns,
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 774, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 564, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 250, in populateSack
    self.doSetup()
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 83, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 177, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 184, in postreposetup_hook
    if downgrade_ftp and _len_non_ftp(repo.urls) == 1:
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 679, in <lambda>
    urls = property(fget=lambda self: self._geturls(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 676, in _geturls
    self._baseurlSetup()
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 647, in _baseurlSetup
    self.check()
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 423, in check
    'Cannot find a valid baseurl for repo: %s' % self.id
RepoError: Cannot find a valid baseurl for repo: rpmfusion-nonfree-updates

Local variables in innermost frame:
self: <yum.yumRepo.YumRepository object at 0x9d5efcc>

How to reproduce
-----
# package-cleanup --orphans
Loaded plugins: auto-update-debuginfo, fastestmirror, presto, refresh-packagekit, remove-with-leaves
Loading mirror speeds from cached hostfile
fedora/metalink                                                                                                                                      |  21 kB     00:00     
Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-updates-released-13&arch=i386 error was
...
Comment 1 Mads Kiilerich 2010-05-06 08:11:07 EDT
Package: yum-utils-1.1.26-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
# package-cleanup --orphans
Loaded plugins: auto-update-debuginfo, fastestmirror, presto, refresh-packagekit, remove-with-leaves
Loading mirror speeds from cached hostfile
fedora/metalink                                                                                                                                      |  21 kB     00:00     
Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorlist?repo=nonfree-fedora-updates-released-13&arch=i386 error was
...

Comment
-----
I would expect an error message, not a stacktrace
Comment 2 Tim Lauridsen 2010-05-07 12:21:38 EDT

*** This bug has been marked as a duplicate of bug 582039 ***

Note You need to log in before you can comment on or make changes to this bug.