Bug 589517 - NetworkManager-0.8.0-11.git20100503.fc13: IPv6-less WiFi does not work
Summary: NetworkManager-0.8.0-11.git20100503.fc13: IPv6-less WiFi does not work
Status: CLOSED DUPLICATE of bug 588814
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 11:06 UTC by Milan Kerslager
Modified: 2010-05-06 23:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 23:24:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Milan Kerslager 2010-05-06 11:06:21 UTC
The latest update to NetworkManager-0.8.0-11.git20100503.fc13 breaks my setup. I have IPv6 disabled (no kernel module, set as "Ignore" in NM). But NM now deactivate WIFi connection as there is no file /proc/sys/net/ipv6/conf/wlan0/accept_ra on my system. The correspondig lines from log are there:

May  6 11:59:59 XXX NetworkManager: <warn> (wlan0): error reading /proc/sys/net/ipv6/conf/wlan0/accept_ra: (4) Failed to open file '/proc/sys/net/ipv6/con
f/wlan0/accept_ra': No such file or directory
May  6 11:59:59 XXX NetworkManager: <info> (wlan0): device state change: 7 -> 9 (reason 0)

NM should not deactivate device if there is no /proc/sys/net/ipv6/conf/wlan0/accept_ra file and IPv6 is set as "Ignore" in NM config.

Comment 1 Dan Williams 2010-05-06 23:24:32 UTC

*** This bug has been marked as a duplicate of bug 588814 ***


Note You need to log in before you can comment on or make changes to this bug.