This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 588814 - IPv4-only connections fail in NetworkManager-0.8.0-11.git20100503
IPv4-only connections fail in NetworkManager-0.8.0-11.git20100503
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 588754 588815 588882 588922 588967 589020 589082 589324 589329 589394 589517 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-05-04 12:42 EDT by Anatoli Sakhnik
Modified: 2010-06-10 15:07 EDT (History)
23 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-0.1.git20100510.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 03:03:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NetworkManager wifi connection failure (4.81 KB, application/octet-stream)
2010-05-04 12:42 EDT, Anatoli Sakhnik
no flags Details
/var/log/messages (part) (5.88 KB, application/octet-stream)
2010-05-04 15:19 EDT, Juan P. Daza P.
no flags Details
/var/log/messages (part) (with sendbus command) (14.84 KB, application/octet-stream)
2010-05-04 15:25 EDT, Juan P. Daza P.
no flags Details
Log with debugging on (2.61 KB, application/x-gzip)
2010-05-04 15:29 EDT, Anatoli Sakhnik
no flags Details
debug output (5.24 KB, application/x-gzip)
2010-05-04 17:04 EDT, Chad Feller
no flags Details
debug log (14.72 KB, text/plain)
2010-05-04 17:54 EDT, jmccann
no flags Details
nm debug log (9.98 KB, text/plain)
2010-05-04 18:34 EDT, jmccann
no flags Details
Another /var/log/messages w/ NM debug output (13.76 KB, text/plain)
2010-05-04 19:54 EDT, James Laska
no flags Details

  None (edit)
Description Anatoli Sakhnik 2010-05-04 12:42:14 EDT
Created attachment 411329 [details]
NetworkManager wifi connection failure

Description of problem:

> The NetworkManager fails to connect with either kernel.

Version-Release number of selected component (if applicable):

> NetworkManager.i686 1:0.8.0-11.git20100503.fc13

How reproducible:

> 100% on the laptop Asus F8SG


Steps to Reproduce:
1. Boot the computer, log in
2.
3.
  
Actual results:

> No wireless connection established

Expected results:

> Connected to local wireless access point

Additional info:

> Downgrade to NetworkManager.i686 1:0.8.0-7.git20100422.fc13 solved the problem. See attached strip of system log.
Comment 1 Peter Robinson 2010-05-04 15:10:24 EDT
I'm seeing exactly the same issues on the two (out of 3) Fedora systems running F-13 that have wireless. The third I ran away scared.

One is an Asus eee Box with an ath9k wireless chipset, the other is a Dell Latitude D630 with an iwlagn wifi.
Comment 2 Dan Williams 2010-05-04 15:12:02 EDT
If you can do the following with the broken NM, that would be great...

1) sudo dbus-send --system --print-reply --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.NetworkManager.SetLogging string:"DEBUG" string:""

2) recreate the problem

3) attach your /var/log/messages (scrubbing and personal information you don't want public) to this bug report

THanks!
Comment 3 Juan P. Daza P. 2010-05-04 15:19:07 EDT
Created attachment 411379 [details]
/var/log/messages (part)

My debug info about this issue.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Juan P. Daza P. 2010-05-04 15:25:47 EDT
Created attachment 411381 [details]
/var/log/messages (part) (with sendbus command)

Debug with sendbus command executed.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Anatoli Sakhnik 2010-05-04 15:29:16 EDT
Created attachment 411384 [details]
Log with debugging on
Comment 6 James Laska 2010-05-04 16:45:18 EDT
After discussion with notting and dcbw, they have recommended adding this issue to F13Blocker.  While this issue may be specific to specific hardware or network setups, Dan feels it is serious enough to warrant investigation and resolution for Fedora 13.
Comment 7 Chad Feller 2010-05-04 17:01:59 EDT
Can confirm, same problem:
Dell Precision M60, Intel wireless (ipw2200)
Comment 8 Chad Feller 2010-05-04 17:04:26 EDT
Created attachment 411411 [details]
debug output

debug output from dbus-send, snipped and scrubbed.
Comment 9 Dan Williams 2010-05-04 17:39:34 EDT
*** Bug 588815 has been marked as a duplicate of this bug. ***
Comment 10 Dan Williams 2010-05-04 17:49:54 EDT
*** Bug 588922 has been marked as a duplicate of this bug. ***
Comment 11 jmccann 2010-05-04 17:54:15 EDT
Created attachment 411418 [details]
debug log
Comment 12 Adam Williamson 2010-05-04 17:55:13 EDT
+1 for this as a blocker, especially since it's a late regression (though no blame attached here, we asked for the NM change in the first place via a different blocker bug).
Comment 13 jmccann 2010-05-04 18:34:12 EDT
Created attachment 411422 [details]
nm debug log
Comment 14 Dan Williams 2010-05-04 19:18:16 EDT
Thanks all.  Upstream fix:

commit ad1017974b68ed107caab8357c41043a0e56f1e7
Author: Dan Williams <dcbw@redhat.com>
Date:   Tue May 4 16:14:29 2010 -0700

    core: treat missing IPv6 setting as "ignore" (rh #588814)
Comment 15 Chad Feller 2010-05-04 19:21:23 EDT
Thanks for the amazing turnaround time on this!
Comment 16 James Laska 2010-05-04 19:54:53 EDT
Created attachment 411439 [details]
Another /var/log/messages w/ NM debug output
Comment 17 Dan Williams 2010-05-04 23:28:52 EDT
*** Bug 588967 has been marked as a duplicate of this bug. ***
Comment 18 Dan Williams 2010-05-04 23:28:59 EDT
*** Bug 588882 has been marked as a duplicate of this bug. ***
Comment 19 Dan Williams 2010-05-05 01:19:24 EDT
*** Bug 588754 has been marked as a duplicate of this bug. ***
Comment 20 Michal Schmidt 2010-05-05 03:41:52 EDT
*** Bug 589020 has been marked as a duplicate of this bug. ***
Comment 21 Fedora Update System 2010-05-05 05:16:18 EDT
NetworkManager-0.8.0-12.git20100504.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc13
Comment 22 Fedora Update System 2010-05-05 05:19:00 EDT
NetworkManager-0.8.0-12.git20100504.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc12
Comment 23 Thomas Meyer 2010-05-05 14:31:49 EDT
NetworkManager-0.8.0-12.git20100504.fc12 fixes this bug for me.
Comment 24 Chad Feller 2010-05-05 14:43:22 EDT
(In reply to comment #23)
> NetworkManager-0.8.0-12.git20100504.fc12 fixes this bug for me.    

Fixed here too.
Comment 25 Dan Williams 2010-05-05 15:27:55 EDT
*** Bug 589082 has been marked as a duplicate of this bug. ***
Comment 26 Dan Williams 2010-05-05 19:14:14 EDT
*** Bug 589324 has been marked as a duplicate of this bug. ***
Comment 27 Fedora Update System 2010-05-05 23:37:43 EDT
NetworkManager-0.8.0-12.git20100504.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc12
Comment 28 Fedora Update System 2010-05-05 23:44:36 EDT
NetworkManager-0.8.0-12.git20100504.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc13
Comment 29 Dan Williams 2010-05-06 01:01:08 EDT
*** Bug 589394 has been marked as a duplicate of this bug. ***
Comment 30 Fedora Update System 2010-05-06 03:02:27 EDT
NetworkManager-0.8.0-12.git20100504.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 31 Anatoli Sakhnik 2010-05-06 17:51:06 EDT
Confirm fixed in Fedora 13
Comment 32 Dan Williams 2010-05-06 19:24:32 EDT
*** Bug 589517 has been marked as a duplicate of this bug. ***
Comment 33 Dan Williams 2010-05-06 19:27:02 EDT
*** Bug 589329 has been marked as a duplicate of this bug. ***
Comment 34 David 2010-05-07 06:43:31 EDT
Great turnaround on this guys thx
Comment 35 Fedora Update System 2010-05-11 02:55:04 EDT
NetworkManager-0.8.1-0.1.git20100510.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-0.1.git20100510.fc12
Comment 36 Fedora Update System 2010-06-10 15:06:43 EDT
NetworkManager-0.8.1-0.1.git20100510.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.