Bug 589532 - Pinentry always opens behind active window
Pinentry always opens behind active window
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pinentry (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
: Regression
: 589530 589537 589538 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 07:36 EDT by Anne
Modified: 2010-05-17 14:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: pinentry-0.8.0-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-17 14:51:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anne 2010-05-06 07:36:50 EDT
Description of problem:
Since the latest update, pinentry is always hidden behind active window

Version-Release number of selected component (if applicable):
pinentry-0.8.0-2.fc13.i686
pinentry-qt-0.8.0-2.fc13.i686
pinentry-gtk-0.8.0-2.fc13.i686


How reproducible:
Constant

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Stanislav Ochotnicky 2010-05-06 11:25:39 EDT
1. Which pinentry this happens with? qt or gtk? 
2. Is there anything special about your window manager/desktop environment? (If
you don't know, then there probably isn't anything special).
Comment 2 Rex Dieter 2010-05-06 11:31:03 EDT
-qt at least.  Various kde folks have seen this since the 0.7.6 -> 0.8.0 upgrade.
Comment 3 Stanislav Ochotnicky 2010-05-06 11:41:17 EDT
OK. I was just making sure (I've seen some weird focus issues with -qt before). I can reproduce now.
Comment 4 Anne 2010-05-06 13:21:27 EDT
@ Stanislav Ochotnicky:  it's qt.  I was using pinentry-qt4 prior to the update.  There's nothing unusual in my environment.
Comment 5 Stanislav Ochotnicky 2010-05-07 08:54:20 EDT
*** Bug 589538 has been marked as a duplicate of this bug. ***
Comment 6 Stanislav Ochotnicky 2010-05-07 08:57:24 EDT
*** Bug 589537 has been marked as a duplicate of this bug. ***
Comment 7 Stanislav Ochotnicky 2010-05-07 08:58:05 EDT
*** Bug 589530 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2010-05-07 10:21:05 EDT
pinentry-0.8.0-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pinentry-0.8.0-2.fc12
Comment 9 Fedora Update System 2010-05-07 10:21:14 EDT
pinentry-0.8.0-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/pinentry-0.8.0-3.fc13
Comment 10 Fedora Update System 2010-05-08 12:11:25 EDT
pinentry-0.8.0-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pinentry'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pinentry-0.8.0-3.fc13
Comment 11 Anne 2010-05-09 07:43:06 EDT
pinentry-0.8.0-3.fc13 fixes the problem on my system.
Comment 12 Fedora Update System 2010-05-10 13:05:45 EDT
pinentry-0.8.0-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pinentry'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pinentry-0.8.0-2.fc12
Comment 13 Fedora Update System 2010-05-17 14:51:25 EDT
pinentry-0.8.0-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-05-17 14:53:09 EDT
pinentry-0.8.0-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.