Bug 606794 - saving settings in system-config-network generates empty /etc/modprobe.conf
saving settings in system-config-network generates empty /etc/modprobe.conf
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-network (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On: 589593
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-22 10:07 EDT by Harald Hoyer
Modified: 2010-08-24 05:13 EDT (History)
5 users (show)

See Also:
Fixed In Version: system-config-network-1.6.0.el6.2-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 589593
Environment:
Last Closed: 2010-08-24 05:13:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2010-06-22 10:07:01 EDT
+++ This bug was initially created as a clone of Bug #589593 +++

Description of problem:
If I use system-config-network to change my ethernet connection to NOT be controlled by NetworkManager, then deactivate it, an empty /etc/modprobe.conf file is generated.  There shouldn't even be any code referring to this file anymore, AFAIK.  This may explain the mysterious empty modprobe.conf files that many people have seen, that cause warnings on boot.  The same thing happens on F12.

Version-Release number of selected component (if applicable):
system-config-network-1.6.0-2.fc14.noarch

How reproducible:
always

Steps to Reproduce:
1. Use s-c-n to edit ethernet connection so it's not controlled by NetworkManager.
2. Use s-c-n to deactivate the ethernet connection.
  
Actual results:
An empty /etc/modprobe.conf file is generated.

--- Additional comment from andre@bwh.harvard.edu on 2010-05-22 16:22:39 EDT ---

Right after installing F13 (AKA RC3) I used s-c-n to edit the ethernet connection to add a DHCP hostname.  Upon saving I had an empty /etc/modprobe.conf file.  It seems that just about any use of s-c-n to edit network settings triggers this.

--- Additional comment from andre@bwh.harvard.edu on 2010-05-27 23:35:32 EDT ---

Simplified procedure for reproducing: start s-c-n, then File/Save.  That's it.  The file /etc/modprobe.conf is immediately created.

--- Additional comment from frankly3d@gmail.com on 2010-05-28 10:21:18 EDT ---

But, if you close the applet with the x.
It doesn't create /etc/modprobe.conf

or s-c-n-tui
doesn't create it either.

--- Additional comment from andre@bwh.harvard.edu on 2010-05-28 16:34:03 EDT ---

Confirmed - if I run s-c-n-tui and immediately select "Save&Quit", it doesn't create the file.  Interesting.

--- Additional comment from dcantrell@redhat.com on 2010-06-11 14:17:09 EDT ---

*** Bug 598764 has been marked as a duplicate of this bug. ***

--- Additional comment from jpopelka@redhat.com on 2010-06-16 12:28:10 EDT ---

Fixed upstream (commit f6d58b7).
Comment 1 RHEL Product and Program Management 2010-06-22 10:13:01 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Alexander Todorov 2010-08-24 05:13:29 EDT
In latest snap #12 there's only system-config-network-tui, not the GUI part.

Note You need to log in before you can comment on or make changes to this bug.