Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 589809 - SELinux está negando a /usr/libexec/accounts-daemon el acceso "remove_name" on custom.conf.3MWECV
SELinux está negando a /usr/libexec/accounts-daemon el acceso "remove_name" ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:ac85b33c70b...
:
: 589810 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 19:33 EDT by Iván Jiménez
Modified: 2010-08-19 04:29 EDT (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-15.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 17:47:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iván Jiménez 2010-05-06 19:33:04 EDT
Resúmen:

SELinux está negando a /usr/libexec/accounts-daemon el acceso "remove_name" on
custom.conf.3MWECV

Descripción Detallada:

[accounts-daemon es un tipo permisivo (accountsd_t). Este acceso no fue
denegado.]

SELinux negó el acceso requerido por accounts-daemon. No se esperaba que este
acceso fuera requerido por accounts-daemon, y puede ser indicio de un intento de
ataque. También es posible que la versión específica o la configuración de
la aplicación esté provocando esta necesidad de acceso adicional

Permitiendo Acceso:

Puede generar un módulo de política local para permitir este acceso. Vea FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Por favor, informe
este error.

Información Adicional:

Contexto Fuente               system_u:system_r:accountsd_t:s0-s0:c0.c1023
Contexto Destino              system_u:object_r:etc_t:s0
Objetos Destino               custom.conf.3MWECV [ dir ]
Fuente                        accounts-daemon
Dirección de Fuente          /usr/libexec/accounts-daemon
Puerto                        <Desconocido>
Nombre de Equipo              (eliminado)
Paquetes RPM Fuentes          accountsservice-0.6-2.fc13
Paquetes RPM Destinos         
RPM de Políticas             selinux-policy-3.7.19-10.fc13
SELinux Activado              True
Tipo de Política             targeted
Modo Obediente                Enforcing
Nombre de Plugin              catchall
Nombre de Equipo              (eliminado)
Plataforma                    Linux (eliminado)
                              2.6.33.3-79.fc13.x86_64 #1 SMP Mon May 3 22:37:18
                              UTC 2010 x86_64 x86_64
Cantidad de Alertas           3
Visto por Primera Vez         jue 06 may 2010 12:22:45 COT
Visto por Última Vez         jue 06 may 2010 12:22:45 COT
ID Local                      a9c9cd9d-b80a-47ad-8218-f86bc0fe9d04
Números de Línea            

Mensajes de Auditoría Crudos 

node=(eliminado) type=AVC msg=audit(1273166565.451:58): avc:  denied  { remove_name } for  pid=11003 comm="accounts-daemon" name="custom.conf.3MWECV" dev=dm-0 ino=68 scontext=system_u:system_r:accountsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=dir

node=(eliminado) type=AVC msg=audit(1273166565.451:58): avc:  denied  { rename } for  pid=11003 comm="accounts-daemon" name="custom.conf.3MWECV" dev=dm-0 ino=68 scontext=system_u:system_r:accountsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(eliminado) type=AVC msg=audit(1273166565.451:58): avc:  denied  { unlink } for  pid=11003 comm="accounts-daemon" name="custom.conf" dev=dm-0 ino=82062 scontext=system_u:system_r:accountsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(eliminado) type=SYSCALL msg=audit(1273166565.451:58): arch=c000003e syscall=82 success=yes exit=0 a0=1e1a230 a1=40aa10 a2=1e16680 a3=7fff49027120 items=0 ppid=1 pid=11003 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="accounts-daemon" exe="/usr/libexec/accounts-daemon" subj=system_u:system_r:accountsd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,accounts-daemon,accountsd_t,etc_t,dir,remove_name
audit2allow suggests:

#============= accountsd_t ==============
allow accountsd_t etc_t:dir remove_name;
allow accountsd_t etc_t:file { rename unlink };
Comment 1 Daniel Walsh 2010-05-07 10:13:26 EDT
Fixed in selinux-policy-3.7.19-14.fc13.noarch
Comment 2 Daniel Walsh 2010-05-07 10:18:09 EDT
*** Bug 589810 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2010-05-11 17:16:23 EDT
selinux-policy-3.7.19-15.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-15.fc13
Comment 4 Fedora Update System 2010-05-12 08:19:08 EDT
selinux-policy-3.7.19-15.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-15.fc13
Comment 5 Fedora Update System 2010-05-15 16:21:21 EDT
selinux-policy-3.7.19-15.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-15.fc13
Comment 6 Fedora Update System 2010-05-18 17:45:53 EDT
selinux-policy-3.7.19-15.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.