Bug 589810 - SELinux está negando a /usr/libexec/accounts-daemon el acceso "write" on /etc/gdm
SELinux está negando a /usr/libexec/accounts-daemon el acceso "write" ...
Status: CLOSED DUPLICATE of bug 589809
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:693ea41a95e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 19:34 EDT by Iván Jiménez
Modified: 2010-05-26 21:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 10:18:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iván Jiménez 2010-05-06 19:34:23 EDT
Resúmen:

SELinux está negando a /usr/libexec/accounts-daemon el acceso "write" on
/etc/gdm

Descripción Detallada:

[accounts-daemon es un tipo permisivo (accountsd_t). Este acceso no fue
denegado.]

SELinux negó el acceso requerido por accounts-daemon. No se esperaba que este
acceso fuera requerido por accounts-daemon, y puede ser indicio de un intento de
ataque. También es posible que la versión específica o la configuración de
la aplicación esté provocando esta necesidad de acceso adicional

Permitiendo Acceso:

Puede generar un módulo de política local para permitir este acceso. Vea FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Por favor, informe
este error.

Información Adicional:

Contexto Fuente               system_u:system_r:accountsd_t:s0-s0:c0.c1023
Contexto Destino              system_u:object_r:etc_t:s0
Objetos Destino               /etc/gdm [ dir ]
Fuente                        accounts-daemon
Dirección de Fuente          /usr/libexec/accounts-daemon
Puerto                        <Desconocido>
Nombre de Equipo              (eliminado)
Paquetes RPM Fuentes          accountsservice-0.6-2.fc13
Paquetes RPM Destinos         gdm-2.30.2-1.fc13
RPM de Políticas             selinux-policy-3.7.19-10.fc13
SELinux Activado              True
Tipo de Política             targeted
Modo Obediente                Enforcing
Nombre de Plugin              catchall
Nombre de Equipo              (eliminado)
Plataforma                    Linux (eliminado)
                              2.6.33.3-79.fc13.x86_64 #1 SMP Mon May 3 22:37:18
                              UTC 2010 x86_64 x86_64
Cantidad de Alertas           4
Visto por Primera Vez         jue 06 may 2010 12:22:45 COT
Visto por Última Vez         jue 06 may 2010 12:22:45 COT
ID Local                      a91c1f2d-cdd5-4234-82e5-5bcba590a79b
Números de Línea            

Mensajes de Auditoría Crudos 

node=(eliminado) type=AVC msg=audit(1273166565.325:57): avc:  denied  { write } for  pid=11003 comm="accounts-daemon" name="gdm" dev=dm-0 ino=82052 scontext=system_u:system_r:accountsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=dir

node=(eliminado) type=AVC msg=audit(1273166565.325:57): avc:  denied  { add_name } for  pid=11003 comm="accounts-daemon" name="custom.conf.3MWECV" scontext=system_u:system_r:accountsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=dir

node=(eliminado) type=AVC msg=audit(1273166565.325:57): avc:  denied  { create } for  pid=11003 comm="accounts-daemon" name="custom.conf.3MWECV" scontext=system_u:system_r:accountsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(eliminado) type=AVC msg=audit(1273166565.325:57): avc:  denied  { write } for  pid=11003 comm="accounts-daemon" name="custom.conf.3MWECV" dev=dm-0 ino=68 scontext=system_u:system_r:accountsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(eliminado) type=SYSCALL msg=audit(1273166565.325:57): arch=c000003e syscall=2 success=yes exit=10 a0=1e16690 a1=c2 a2=1b6 a3=1c items=0 ppid=1 pid=11003 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="accounts-daemon" exe="/usr/libexec/accounts-daemon" subj=system_u:system_r:accountsd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,accounts-daemon,accountsd_t,etc_t,dir,write
audit2allow suggests:

#============= accountsd_t ==============
#!!!! The source type 'accountsd_t' can write to a 'dir' of the following types:
# accountsd_var_lib_t, var_lib_t

allow accountsd_t etc_t:dir { write add_name };
allow accountsd_t etc_t:file { write create };
Comment 1 Daniel Walsh 2010-05-07 10:18:09 EDT

*** This bug has been marked as a duplicate of bug 589809 ***

Note You need to log in before you can comment on or make changes to this bug.