Bug 58990 - vncserver uses -fp unix/:7100 and Xvnc coredumps when it's not available.
vncserver uses -fp unix/:7100 and Xvnc coredumps when it's not available.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: vnc (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
: 60347 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-28 18:16 EST by Aleksey Nogin
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-29 12:13:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vnc-fp.patch (878 bytes, patch)
2002-01-29 12:11 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Aleksey Nogin 2002-01-28 18:16:58 EST
Reproducible: always
To reproduce:
1) Stop xfs
2) Try running vncserver (the one in /usr/bin)

Expected: something reasonable.
Actual: Xvnc dies (sometimes with a coredump).

I see at least two issues here:
- vncserver always uses -fp unix/:7100 and there is no way to override that in a
config file (I can edit the /usr/bin/vncserver directly, but that is not a
config file).
- Xvnc dies without a meaningful error message when -fp points to a non-existing
server.

P.S. In general, a setup with a central font server and no local ones breaks
many RH scripts... Would it make sense to have an extra configuration file in
sysconfig that everybody (vncserver, Xconfigurator, etc) could use?
Comment 1 Tim Waugh 2002-01-29 03:23:48 EST
With the 7.2 package there was a core dump problem to do with xfs when
_exiting_ Xvnc: could it be that you are seeing?  It's been fixed since then..

You can override the font path on the command line using -fp FONTPATH; does that
help?

Comment 2 Aleksey Nogin 2002-01-29 11:26:13 EST
> With the 7.2 package there was a core dump problem to do with xfs when
> _exiting_ Xvnc: could it be that you are seeing?

No, definitely not - this started happening when I disabled the local server and
went away when I changed the vncviewer script to use the remote server instead.
And it definitely was during startup

> You can override the font path on the command line using -fp FONTPATH; does that
> help?

Not really, there are several users besides me who use vncserver and I need a
default that works. Would it be better to extract the default from XF86Config
(or -4) if that config is present? Or should we have a separate configuration
file (that Xconfigurator could consult too)?

Comment 3 Tim Waugh 2002-01-29 12:10:20 EST
For the time being, in lieu of a real configuration file to look at in an easy way,
I used this replacement vnc-fp.patch:
Comment 4 Tim Waugh 2002-01-29 12:11:03 EST
Created attachment 43936 [details]
vnc-fp.patch
Comment 5 Tim Waugh 2002-01-30 09:19:25 EST
Patched in vnc-3.3.3r2-26.
Comment 6 Tim Waugh 2002-02-26 07:01:52 EST
*** Bug 60347 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.