Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 590013 - virt-image --help : UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 165: ordinal not in range(128)
virt-image --help : UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 ...
Status: CLOSED DUPLICATE of bug 582748
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 10:13 EDT by Carl G.
Modified: 2010-05-10 08:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 10:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl G. 2010-05-07 10:13:00 EDT
show program's version number and exit
show this help message and exit
Se connecter à l'hyperviseur via l'URI
Nom de l'instance de l'invité
Mémoire à allouer à l'instance de l'invité en Mo
UUID for the guest.
Nombre d'UC virtuelles à configurer pour votre invité
Vérifier si il n'y a pas plus d'UC virtuelles que d'UC
physiques et prévenir si c'est le cas.
Donner l'UC physique que le domaine peut utiliser
The OS type being installed, e.g. 'linux', 'unix',
'windows'
The OS variant being installed, e.g. 'fedora6',
'rhel5', 'solaris10', 'win2k'
Disables APIC for fully virtualized guest
Disables ACPI for fully virtualized guest
Specify a network interface. Ex:
--network bridge=mybr0
--network network=libvirt_network_name
--network network=mynet,model=e1000,mac=00:11...
Utiliser VNC pour la prise en charge de l'interface
graphique
Port à utiliser pour VNC
Address to listen on for VNC connections.
set up keymap for the VNC console
Utiliser SDL pour la prise en charge de l'interface
graphique
Ne pas configurer de console graphique pour l'invité.
Affiche le XML de libvirt, mais ne démarre pas le
domaine
L'index « zero-based » du secteur de boot à utiliser.
Overwrite, or destroy, an existing image with the same
name
Skip disk checksum verification process
Imprime des informations de débogage
Do not prompt for input. Answers yes where applicable,
terminates for all other prompts
ERROR:root:'ascii' codec can't decode byte 0xc3 in position 165: ordinal not in range(128)
Traceback (most recent call last):
  File "/usr/bin/virt-image", line 260, in <module>
    main()
  File "/usr/bin/virt-image", line 173, in main
    options = parse_args()
  File "/usr/bin/virt-image", line 162, in parse_args
    (options,args) = parser.parse_args()
  File "/usr/lib64/python2.6/optparse.py", line 1394, in parse_args
    stop = self._process_args(largs, rargs, values)
  File "/usr/lib64/python2.6/optparse.py", line 1434, in _process_args
    self._process_long_opt(rargs, values)
  File "/usr/lib64/python2.6/optparse.py", line 1509, in _process_long_opt
    option.process(opt, value, values, self)
  File "/usr/lib64/python2.6/optparse.py", line 788, in process
    self.action, self.dest, opt, value, values, parser)
  File "/usr/lib64/python2.6/optparse.py", line 810, in take_action
    parser.print_help()
  File "/usr/lib/python2.6/site-packages/virtinst/cli.py", line 60, in print_help
    file.write(self.format_help().encode(encoding, "replace"))
  File "/usr/lib64/python2.6/optparse.py", line 1644, in format_help
    result.append(self.format_option_help(formatter))
  File "/usr/lib64/python2.6/optparse.py", line 1631, in format_option_help
    return "".join(result[:-1])
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 165: ordinal not in range(128)


virt-manager-0.8.3-3.fc13.noarch
Comment 1 Cole Robinson 2010-05-07 10:37:38 EDT

*** This bug has been marked as a duplicate of bug 582748 ***
Comment 2 Carl G. 2010-05-07 11:20:56 EDT
Are you sure it's a dupe ?

I'm gettting a backtrace while 582748 doesn't.
Comment 3 Cole Robinson 2010-05-10 08:35:55 EDT
It's all fixed by the same patches, so while not technically the same issue it's pretty close.

Note You need to log in before you can comment on or make changes to this bug.