Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 590030 - [abrt] crash in eog-2.28.2-1.fc12: raise: Process /usr/bin/eog was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in eog-2.28.2-1.fc12: raise: Process /usr/bin/eog was killed by ...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: eog
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Siddhesh Poyarekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:33bffc341633d8b9fdca7b38588...
: 600802 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 14:49 UTC by Benjamin Kahn
Modified: 2015-09-14 00:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-27 21:16:31 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (30.49 KB, text/plain)
2010-05-07 14:49 UTC, Benjamin Kahn
no flags Details
Photo which crashed eog (69.74 KB, image/jpeg)
2010-05-07 14:50 UTC, Benjamin Kahn
no flags Details

Description Benjamin Kahn 2010-05-07 14:49:00 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: eog /home/xkahn/.cache/.fr-KWErAl/web/favicon.ico
component: eog
crash_function: raise
executable: /usr/bin/eog
global_uuid: 33bffc341633d8b9fdca7b385887af973e0bbc43
kernel: 2.6.32.11-99.fc12.x86_64
package: eog-2.28.2-1.fc12
rating: 4
reason: Process /usr/bin/eog was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

comment
-----
I created an image file from a video using this command line:
ffmpeg -i movie.mov -f mjpeg -t 0.001 -ss 00:00:02 movie.jpg

Note that the -f parameter is wrong.  However, gqview can open the file fine and does not crash.

How to reproduce
-----
1. Open image file
2. Get crash
3.

Comment 1 Benjamin Kahn 2010-05-07 14:49:05 UTC
Created attachment 412369 [details]
File: backtrace

Comment 2 Benjamin Kahn 2010-05-07 14:50:17 UTC
Created attachment 412370 [details]
Photo which crashed eog

Comment 3 Fedora Admin XMLRPC Client 2010-07-02 09:21:22 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Siddhesh Poyarekar 2010-07-04 20:17:34 UTC
Seems to be fixed in rawhide. I can open the photo fine with eog-2.31.4-0.1.20100623git.fc14.x86_64

Comment 5 Siddhesh Poyarekar 2010-08-27 20:56:56 UTC
Does the crash happen every time you open the image? I can open the image fine on my F-12 vm and also on F-13.

Comment 6 Benjamin Kahn 2010-08-27 21:16:31 UTC
It's opening fine now.  I have no idea what has changed; the version of eog is the same.  Reading the backtrace, it looks like something to do with generating the icon for the image?

Comment 7 Siddhesh Poyarekar 2010-08-27 22:58:20 UTC
*** Bug 600802 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.