Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 590058 - AttributeError: 'NoneType' object has no attribute 'rfind'
AttributeError: 'NoneType' object has no attribute 'rfind'
Status: CLOSED DUPLICATE of bug 589967
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
anaconda_trace_hash:b41bb61842aa42b79...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 11:47 EDT by James G. Brown III
Modified: 2014-12-01 18:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-07 11:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (400.11 KB, text/plain)
2010-05-07 11:47 EDT, James G. Brown III
no flags Details
anaconda.log (7.17 KB, application/octet-stream)
2010-05-07 11:53 EDT, James G. Brown III
no flags Details
syslog (342.33 KB, application/octet-stream)
2010-05-07 11:53 EDT, James G. Brown III
no flags Details

  None (edit)
Description James G. Brown III 2010-05-07 11:47:17 EDT
The following was filed automatically by anaconda:
anaconda 13.21.36 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/posixpath.py", line 111, in basename
    i = p.rfind('/') + 1
  File "/usr/lib/anaconda/storage/devicetree.py", line 1360, in handleUdevDiskLabelFormat
    bypath = os.path.basename(deviceNameToDiskByPath(device.name))
  File "/usr/lib/anaconda/storage/devicetree.py", line 1715, in handleUdevDeviceFormat
    self.handleUdevDiskLabelFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1299, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 2004, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 379, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 103, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1260, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'NoneType' object has no attribute 'rfind'
Comment 1 James G. Brown III 2010-05-07 11:47:19 EDT
Created attachment 412383 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2010-05-07 11:53:02 EDT

*** This bug has been marked as a duplicate of bug 589967 ***
Comment 3 James G. Brown III 2010-05-07 11:53:36 EDT
Created attachment 412384 [details]
anaconda.log
Comment 4 James G. Brown III 2010-05-07 11:53:57 EDT
Created attachment 412385 [details]
syslog

Note You need to log in before you can comment on or make changes to this bug.