Bug 589967 - AttributeError: 'NoneType' object has no attribute 'rfind'
AttributeError: 'NoneType' object has no attribute 'rfind'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: David Cantrell
Release Test Team
anaconda_trace_hash:70830a4ddc54d7a2d...
:
: 590058 590548 590885 591254 591275 591315 592099 592279 592867 592868 592869 593215 (view as bug list)
Depends On:
Blocks: 582286
  Show dependency treegraph
 
Reported: 2010-05-07 08:26 EDT by Marian Ganisin
Modified: 2010-07-02 16:48 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-13.21.38-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:48:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (52.63 KB, text/plain)
2010-05-07 08:26 EDT, Marian Ganisin
no flags Details
anaconda.log (7.17 KB, text/plain)
2010-05-07 11:54 EDT, James G. Brown III
no flags Details
syslog (342.33 KB, text/plain)
2010-05-07 11:55 EDT, James G. Brown III
no flags Details

  None (edit)
Description Marian Ganisin 2010-05-07 08:26:13 EDT
The following was filed automatically by anaconda:
anaconda 13.21.36 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/posixpath.py", line 111, in basename
    i = p.rfind('/') + 1
  File "/usr/lib/anaconda/storage/devicetree.py", line 1360, in handleUdevDiskLabelFormat
    bypath = os.path.basename(deviceNameToDiskByPath(device.name))
  File "/usr/lib/anaconda/storage/devicetree.py", line 1715, in handleUdevDeviceFormat
    self.handleUdevDiskLabelFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1299, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1965, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 379, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 103, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1348, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1261, in nextClicked
    self.setScreen ()
AttributeError: 'NoneType' object has no attribute 'rfind'
Comment 1 Marian Ganisin 2010-05-07 08:26:16 EDT
Created attachment 412329 [details]
Attached traceback automatically from anaconda.
Comment 2 Marian Ganisin 2010-05-07 08:46:07 EDT
This happens with virtio disk
Comment 4 RHEL Product and Program Management 2010-05-07 10:08:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Chris Lumens 2010-05-07 11:53:02 EDT
*** Bug 590058 has been marked as a duplicate of this bug. ***
Comment 6 James G. Brown III 2010-05-07 11:54:39 EDT
Created attachment 412387 [details]
anaconda.log
Comment 7 James G. Brown III 2010-05-07 11:55:06 EDT
Created attachment 412388 [details]
syslog
Comment 9 David Cantrell 2010-05-07 18:02:44 EDT
This bug is related to the changes made for bug #589713.  Fix is quite simple.  Here's the patch:

diff --git a/storage/devicetree.py b/storage/devicetree.py
index 1ed73c1..c171968 100644
--- a/storage/devicetree.py
+++ b/storage/devicetree.py
@@ -1357,10 +1357,12 @@ class DeviceTree(object):
             initcb = lambda: True
         else:
             description = device.description or device.model
-            bypath = os.path.basename(deviceNameToDiskByPath(device.name))
+            bypath = deviceNameToDiskByPath(device.name)
             if bypath:
+                bypath = os.path.basename(bypath)
                 details = "\n\nDevice details:\n%s" % (bypath,)
             else:
+                bypath = device.name
                 details = ""
 
             initcb = lambda: self.intf.questionInitializeDisk(bypath,

Can I get a qa_ack on this one?
Comment 10 Marian Ganisin 2010-05-10 04:07:21 EDT
qa_ack granted
Comment 11 Hans de Goede 2010-05-10 04:55:06 EDT
*** Bug 590548 has been marked as a duplicate of this bug. ***
Comment 15 David Cantrell 2010-05-10 19:38:25 EDT
*** Bug 590885 has been marked as a duplicate of this bug. ***
Comment 17 Chris Lumens 2010-05-11 14:46:37 EDT
*** Bug 591254 has been marked as a duplicate of this bug. ***
Comment 18 David Cantrell 2010-05-11 16:27:54 EDT
*** Bug 591275 has been marked as a duplicate of this bug. ***
Comment 19 Alexander Todorov 2010-05-11 17:04:54 EDT
*** Bug 591315 has been marked as a duplicate of this bug. ***
Comment 21 Bill Nottingham 2010-05-13 16:56:13 EDT
*** Bug 592099 has been marked as a duplicate of this bug. ***
Comment 22 Alexander Todorov 2010-05-14 05:41:10 EDT
With anaconda-13.21.39-1.el6 and steps to reproduce from duplicate bug:
https://bugzilla.redhat.com/show_bug.cgi?id=591275#c2

Install completes successfully. Moving to VERIFIED.
Comment 23 Chris Lumens 2010-05-14 09:51:42 EDT
*** Bug 592279 has been marked as a duplicate of this bug. ***
Comment 24 Hans de Goede 2010-05-17 07:03:31 EDT
*** Bug 592869 has been marked as a duplicate of this bug. ***
Comment 25 Hans de Goede 2010-05-17 07:03:35 EDT
*** Bug 592868 has been marked as a duplicate of this bug. ***
Comment 26 Hans de Goede 2010-05-17 07:03:39 EDT
*** Bug 592867 has been marked as a duplicate of this bug. ***
Comment 27 Bill Nottingham 2010-05-18 10:56:17 EDT
*** Bug 593215 has been marked as a duplicate of this bug. ***
Comment 29 releng-rhel@redhat.com 2010-07-02 16:48:42 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.