Bug 590090 - latest upower version prevents hibernation
latest upower version prevents hibernation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: upower (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 590165 590466 592703 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 13:15 EDT by Marcus Specht
Modified: 2010-05-19 15:07 EDT (History)
9 users (show)

See Also:
Fixed In Version: upower-0.9.4-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-19 15:07:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upower --dump with lid closed (1.80 KB, text/plain)
2010-05-07 22:14 EDT, Will Woods
no flags Details

  None (edit)
Description Marcus Specht 2010-05-07 13:15:09 EDT
Description of problem:
with the latest version of upower (upower-0.9.3-1.fc13.i686)  my netbook (eee 1000h) does not go to sleep any more. Reverting to upower-0.9.2-1.fc13.i686 fixes the problem.

Version-Release number of selected component (if applicable):
upower-0.9.3-1.fc13.i686

How reproducible:
close lid

Steps to Reproduce:
1. close lid
2. nothing happens

  
Actual results:
no suspend

Expected results:
should suspend
Comment 1 Richard Hughes 2010-05-07 13:55:44 EDT
What's the output of "upower --dump" -- thanks?
Comment 2 Marcus Specht 2010-05-07 16:07:05 EDT
Device: /org/freedesktop/UPower/devices/line_power_AC0
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/ACPI0003:00/power_supply/AC0
  power supply:         yes
  updated:              Fri May  7 21:59:56 2010 (304 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    online:             yes

Device: /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/PNP0C0A:00/power_supply/BAT0
  vendor:               ASUS
  model:                1000H
  power supply:         yes
  updated:              Fri May  7 22:00:02 2010 (298 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               fully-charged
    energy:              90.4428 Wh
    energy-empty:        0 Wh
    energy-full:         90.4428 Wh
    energy-full-design:  549.78 Wh
    energy-rate:         0 W
    voltage:             8.368 V
    percentage:          100%
    capacity:            16.4507%
    technology:          lithium-ion

Daemon:
  daemon-version:  0.9.2
  can-suspend:     yes
  can-hibernate    yes
  on-battery:      no
  on-low-battery:  no
  lid-is-closed:   no
  lid-is-present:   yes
Comment 3 Richard Hughes 2010-05-07 16:38:25 EDT
Could you try rebuilding the upower package from here please http://people.freedesktop.org/~hughsient/fedora/13/SRPMS/ and trying that? Thanks.
Comment 4 Marcus Specht 2010-05-07 17:11:17 EDT
Did not work for me.
Comment 5 Will Woods 2010-05-07 22:14:26 EDT
Created attachment 412472 [details]
upower --dump with lid closed

I obtained this log by doing:
  sleep 5; upower --dump > log.txt
and then closing the lid real quick. heh.

Note that the output does say "lid-is-closed: yes" - so it's correctly detected lid closure, but failing to suspend the machine for some reason.
Comment 6 Marcus Specht 2010-05-08 02:37:52 EDT
This is the result:
Device: /org/freedesktop/UPower/devices/line_power_AC0
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/ACPI0003
:00/power_supply/AC0
  power supply:         yes
  updated:              Sat May  8 08:33:48 2010 (102 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    online:             yes

Device: /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/PNP0C0A:
00/power_supply/BAT0
  vendor:               ASUS
  model:                1000H
  power supply:         yes
  updated:              Sat May  8 08:33:56 2010 (94 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               fully-charged
    energy:              90.4428 Wh
    energy-empty:        0 Wh
    energy-full:         90.4428 Wh
    energy-full-design:  549.78 Wh
    energy-rate:         0 W
    voltage:             8.362 V
    percentage:          100%
    capacity:            16.4507%
    technology:          lithium-ion
  History (charge):
    1273300432	100.000	fully-charged
    1273300430	0.000	unknown
  History (rate):
    1273300430	0.000	unknown

Daemon:
  daemon-version:  0.9.4
  can-suspend:     yes
  can-hibernate    yes
  on-battery:      no
  on-low-battery:  no
  lid-is-closed:   yes
  lid-is-present:   yes
Comment 7 Will Woods 2010-05-09 21:08:02 EDT
daemon 0.9.4 makes no difference here either. upower --dump log is essentially identical, save the timestamps, voltage numbers, and (of course) the daemon version number.
Comment 8 Matthias Runge 2010-05-10 02:39:40 EDT
I've noticed, (my) system suspends fine via System-Menu, shutdown Item, then select suspend.
Comment 9 Will Woods 2010-05-10 13:09:42 EDT
Right, same here. I diffed 0.9.2 and 0.9.3 and noticed some changes which might cause this behavior - specifically it changed from doing:

  g_object_set (backend->priv->daemon, "lid-is-closed", is_closed, NULL);

to:

  priv->lid_is_closed = lid_is_closed;

which by itself may not cause the proper events/notifications to be fired. hughsie has the details; hopefully he'll be able to confirm whether or not this is the cause of the problem.

In the meantime, 'yum downgrade upower' (followed by a reboot, or some other way of starting upower) will restore the expected behavior.
Comment 10 Bastien Nocera 2010-05-10 16:28:23 EDT
*** Bug 590466 has been marked as a duplicate of this bug. ***
Comment 11 Richard Hughes 2010-05-10 17:49:06 EDT
Can you try the upower package here please: http://people.freedesktop.org/~hughsient/fedora/13/SRPMS/
Comment 12 Will Woods 2010-05-10 18:25:48 EDT
Success! upower-0.9.4-0.23.fc13 restores the expected suspend-on-lid-close behavior.
Comment 13 Richard Hughes 2010-05-11 05:49:43 EDT
Cool, thanks for testing. It proves the QA process is working as expected :-)

I'll roll a new upstream release in a few days and push it to updates like normal. Thanks.
Comment 14 Fedora Update System 2010-05-12 10:26:28 EDT
upower-0.9.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/upower-0.9.4-1.fc13
Comment 15 Fedora Update System 2010-05-13 15:26:54 EDT
upower-0.9.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update upower'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/upower-0.9.4-1.fc13
Comment 16 Masood 2010-05-14 21:59:35 EDT
*** Bug 590165 has been marked as a duplicate of this bug. ***
Comment 17 Jeff Layton 2010-05-16 07:43:54 EDT
*** Bug 592703 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2010-05-19 15:07:31 EDT
upower-0.9.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.