Bug 590159 - ALSA woke us up to write new data to the device, but there was actually nothing to write
Summary: ALSA woke us up to write new data to the device, but there was actually nothi...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jaroslav Kysela
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
: 595948 (view as bug list)
Depends On:
Blocks: 574844 595948 600311
TreeView+ depends on / blocked
 
Reported: 2010-05-07 21:05 UTC by Tim Burke
Modified: 2010-11-15 14:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 14:25:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ALSA: Fix PCM ring buffer issues (31.58 KB, patch)
2010-06-23 11:34 UTC, Jaroslav Kysela
no flags Details | Diff
ALSA: Fix PCM ring buffer issues and HDA Intel ring buffer pointer updates (33.34 KB, patch)
2010-06-24 12:10 UTC, Jaroslav Kysela
no flags Details | Diff

Description Tim Burke 2010-05-07 21:05:04 UTC
Running snapshot 2 kernel, 2.6.32-24.el6.x86_64 and see the below error in /var/log/messages.  I wasn't running any audio.  From a customer perspective this looks alarming and I question whether it would result in a lot of calls.

This occurred on a Lenovo T500 (standard issue)

May  7 14:14:48 localhost pulseaudio[2635]: alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
May  7 14:14:48 localhost pulseaudio[2635]: alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.
May  7 14:14:48 localhost pulseaudio[2635]: alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.

-------------------------------

[root@localhost log]# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:03.2 IDE interface: Intel Corporation Mobile 4 Series Chipset PT IDER Controller (rev 07)
00:03.3 Serial controller: Intel Corporation Mobile 4 Series Chipset AMT SOL Redirection (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
15:00.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
15:00.3 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev ff)
15:00.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 11)
15:00.5 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 11)
[root@localhost log]#

Comment 2 RHEL Product and Program Management 2010-05-07 22:17:20 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Jaroslav Kysela 2010-06-23 11:34:57 UTC
Created attachment 426241 [details]
ALSA: Fix PCM ring buffer issues

This patch should solve the null wake_up from the ALSA driver side. I believe, it will fix also the problem mentioned in the bug#600944.

Comment 4 Jaroslav Kysela 2010-06-23 11:41:53 UTC
(In reply to comment #3)
> Created an attachment (id=426241) [details]
> ALSA: Fix PCM ring buffer issues
> 
> This patch should solve the null wake_up from the ALSA driver side. I believe,
> it will fix also the problem mentioned in the bug#600944.    

The right bug number is bug#600311 (wrong copy-and-paste).

Comment 5 Nikola Pajkovsky 2010-06-23 12:11:00 UTC
do you have a kernel build? I will try it.

Comment 10 Jaroslav Kysela 2010-06-24 12:10:16 UTC
Created attachment 426544 [details]
ALSA: Fix PCM ring buffer issues and HDA Intel ring buffer pointer updates

This version of patch was posted to the rh-kernel mailing list.

Comment 11 Jaroslav Kysela 2010-06-30 19:04:28 UTC
The pcmring2 test kernel is also available at:

http://people.redhat.com/~jkysela/RHEL6/

Comment 12 Aristeu Rozanski 2010-07-01 16:13:17 UTC
Patch(es) available on kernel-2.6.32-42.el6

Comment 15 Jaroslav Kysela 2010-07-15 21:04:46 UTC
*** Bug 595948 has been marked as a duplicate of this bug. ***

Comment 16 Lubos Kocman 2010-07-16 15:35:28 UTC
I can confirm that I'm no longer facing this issue:

kernel-2.6.32-44.el6.{x86_64,i686)

Comment 17 Petr Beňas 2010-10-06 10:08:58 UTC
found the message in /var/log/messages in 2.6.32-71.el6.x86_64, although the sound works fine. The machine is T500.

pbenas@dhcp-29-193:~$ sudo grep 'alsa-sink.c' /var/log/messages
Oct  5 11:13:58 dhcp-29-193 pulseaudio[2425]: alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
Oct  5 11:13:58 dhcp-29-193 pulseaudio[2425]: alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.
Oct  5 11:13:58 dhcp-29-193 pulseaudio[2425]: alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
pbenas@dhcp-29-193:~$ uname -r
2.6.32-71.el6.x86_64
pbenas@dhcp-29-193:~$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Moving to assigned, if you think the message with sound working does not mind, please move back to ON_QA.

Comment 18 Jaroslav Kysela 2010-10-06 11:20:42 UTC
This is just a warning and it may be not even an issue. Could you reproduce this message easily or it is just a random symptom?

Comment 19 Petr Beňas 2010-10-06 11:40:48 UTC
(In reply to comment #18)
> This is just a warning and it may be not even an issue. Could you reproduce
> this message easily or it is just a random symptom?

Found one such warning in the log dated to yesterday.  Don't know how to reproduce.

Comment 20 releng-rhel@redhat.com 2010-11-15 14:25:08 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.