Bug 590357 - qtoctave upgrade conflict with libquicktime-utils
qtoctave upgrade conflict with libquicktime-utils
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qtoctave (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: nucleo
Fedora Extras Quality Assurance
:
: 590359 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-08 23:42 EDT by Christian Lupien
Modified: 2010-05-10 19:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: qtoctave-0.9.1-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 13:02:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Lupien 2010-05-08 23:42:04 EDT
Description of problem:
The latest update of qtoctave (0.9.1-1.fc12) will not install because there is a conflict with libquicktime-utils. The problem is with /usr/bin/qtinfo
 (what is qtinfo used for in qtoctave?)

Version-Release number of selected component (if applicable):
The installed versions are
libquicktime-utils-1.1.3-3.fc12.i686
qtoctave-0.8.2-2.fc12.i686

The error reported by yum update is:

Transaction Check Error:
  file /usr/bin/qtinfo from install of qtoctave-0.9.1-1.fc12.i686 conflicts with file from package libquicktime-utils-1.1.3-3.fc12.i686
Comment 1 nucleo 2010-05-09 06:42:18 EDT
*** Bug 590359 has been marked as a duplicate of this bug. ***
Comment 2 nucleo 2010-05-09 06:45:00 EDT
(In reply to comment #0)
> The latest update of qtoctave (0.9.1-1.fc12) will not install because there is
> a conflict with libquicktime-utils. The problem is with /usr/bin/qtinfo
I asked QtOctave author how this can be fixed.

>  (what is qtinfo used for in qtoctave?)
It used for displaying octave help.
Comment 3 Kevin Kofler 2010-05-09 11:22:51 EDT
I think we should rename the tool and patch the program to find the renamed tool ASAP to prevent the conflict, if upstream uses a different name later, that shouldn't be too much of a problem given that the tool is normally executed from within QtOctave.
Comment 4 nucleo 2010-05-09 11:39:20 EDT
(In reply to comment #3)
> I think we should rename the tool and patch the program to find the renamed
> tool ASAP to prevent the conflict, if upstream uses a different name later,
> that shouldn't be too much of a problem given that the tool is normally
> executed from within QtOctave.    

This patch renames qtinfo to qtoctave-info
http://nucleo.fedorapeople.org/qtoctave-info.patch

Looks like help working with it but I am not sure about code in
qtoctave-0.9.1/qtoctave/src/main.cpp:

if(get_config("qtinfo_ok").isEmpty() || get_config("qtinfo_ok")=="false" )
{
         oc->command_enter("qtinfo");
}

Should we change qtinfo to qtoctave-info here?
Comment 5 Kevin Kofler 2010-05-09 12:04:24 EDT
No. This calls the qtinfo() Octave function which we aren't renaming at this time.
Comment 6 Fedora Update System 2010-05-09 13:51:54 EDT
qtoctave-0.9.1-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/qtoctave-0.9.1-2.fc13
Comment 7 Fedora Update System 2010-05-09 13:53:28 EDT
qtoctave-0.9.1-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/qtoctave-0.9.1-2.fc12
Comment 8 Fedora Update System 2010-05-09 13:54:27 EDT
qtoctave-0.9.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qtoctave-0.9.1-2.fc11
Comment 9 Fedora Update System 2010-05-10 13:02:18 EDT
qtoctave-0.9.1-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-05-10 13:03:05 EDT
qtoctave-0.9.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-05-10 19:43:10 EDT
qtoctave-0.9.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.