Bug 590373 - evolution doesn't save unfinished messages
evolution doesn't save unfinished messages
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
: 603170 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 05:20 EDT by Pablo Rodríguez
Modified: 2010-06-15 09:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: evolution-2.30.2-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 18:12:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 617557 None None None Never

  None (edit)
Description Pablo Rodríguez 2010-05-09 05:20:04 EDT
Yesterday I downloaded http://download.fedoraproject.org/pub/fedora/linux/releases/test/13-Beta/Live/i686/F13-Beta-i686-Live.iso to check whether this bug (https://bugzilla.gnome.org/show_bug.cgi?id=617557) was fixed in evolution-2.30.

The version included with the ISO above didn't crash when I closed the main window, but it didn't ask whether I wanted to save the unfinished message either.

When I closed the message window, there was no dialogue asking whether I wanted to save the message (I don't know whether there was a crash or not). After restarting, there was no message to recover the unfinished message.

The bug should be easily reproducible:

1. Start evolution.
2. Compose a new message.
3. Write "test" in the body.
4. Switch to evolution main window and close it.
5. If it hasn't been closed, close the new message window.

If there is no message in 4 or 5 asking whether the user wants to save the message, there is a bug there.

Since the version included with evolution was not 2.30 stable, I won't report the bug in GNOME, since I don't know whether this has been fixed already.

Thanks for your help,


Pablo
Comment 1 Matthew Barnes 2010-05-09 10:20:24 EDT
Moving this back upstream with reproducer steps.
Comment 2 Pablo Rodríguez 2010-05-28 10:42:06 EDT
The bug has been already fixed upstream (comments 10 and 11 in upstream report).

And a somehow related bug has been fixed also. Would you be so kind to apply the second patch from https://bugzilla.gnome.org/show_bug.cgi?id=599794 (comments 9 and 10).

Thanks for your help,


Pablo
Comment 3 Milan Crha 2010-05-28 12:54:27 EDT
Note 2.30.2 is planned on June 24th, when also other distributions will adapt all changes done for it.
Comment 4 Fedora Update System 2010-05-28 18:01:06 EDT
evolution-2.30.1-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/evolution-2.30.1-8.fc13
Comment 5 Mika Kuusela 2010-05-30 21:47:20 EDT
The negative feedback in Bodhi was by me, but probably best if I say it here too. I'm kind of new to this, so please excuse any "protocol" mistakes. :)

I reproduced the bug as instructed by Pablo. 
If I close the new message window first, Evolution correctly asks me if I want to save the message. However, if I switch to the main window, close the main window and then close the message, I get no prompt at any stage.

I took evolution-2.30.1-8.fc13.x86_64.rpm and evolution-help-2.30.1-8.fc13.noarch.rpm from Koji and did a yum localinstall.

Regards,

Mika
Comment 6 Fedora Update System 2010-05-31 14:18:12 EDT
evolution-2.30.1-8.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update evolution'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/evolution-2.30.1-8.fc13
Comment 7 Fedora Update System 2010-06-07 18:11:58 EDT
evolution-2.30.1-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Milan Crha 2010-06-15 03:27:08 EDT
*** Bug 603170 has been marked as a duplicate of this bug. ***
Comment 9 Milan Crha 2010-06-15 03:29:15 EDT
I'm reopening the upstream bug because there left one use case, as found
in bug #603170, there is no save question for a composed mail if File->Quit is used in the main application window.
Comment 10 Milan Crha 2010-06-15 09:41:42 EDT
I just committed a fix for this, which will be included in 2.30.2 too, which is about to release next week.

Note You need to log in before you can comment on or make changes to this bug.