Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 603170 - evolution lost in-progress email: does not save draft on exit
evolution lost in-progress email: does not save draft on exit
Status: CLOSED DUPLICATE of bug 590373
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
13
All Linux
low Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 14:14 EDT by David Mansfield
Modified: 2010-06-15 03:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-15 03:27:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mansfield 2010-06-11 14:14:04 EDT
Description of problem:
if I am composing an email and I quit evolution while the compose window is open, the in-progress email is not saved to drafts and is lost permanently.

another scenario for losing an in-progress email is:
- start composing a new email
- close the "main" evolution window
- close the compose window


Version-Release number of selected component (if applicable):
evolution-2.30.1-8.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. start composing
2. in main evolution window file->quit
3. restart evolution and look at empty drafts folder
  
Actual results:
no messages in drafts


Expected results:
in progress emails saved to draft folder

Additional info:
i'm almost positive that this is a new "feature" ;-)
Comment 1 Milan Crha 2010-06-14 11:45:00 EDT
Thanks for a bug report. Are you asked for saving changes when you are closing the composer window? Based on bug #590373 there was no such question, which led to a message lost, but after patch from the upstream bug from there it should ask you for a close confirmation if you did any change in the message itself. It's confusing that you are using the evolution version where this change is supposed to be included, based on that downstream bug report.
Comment 2 David Mansfield 2010-06-14 12:11:11 EDT
in response to your question: no, I am not asked to save my changes, see below:

two points:

1) as per bug#590373,comment#5, that version does not fix the bug as reported, despite that the bug is marked CLOSED/ERRATA ???

2) this bug is ALMOST a duplicate of bug#590373, except that the scope is expanded as follows:

bug#590373 shows what happens if the main window is closed before the composer window

this bug also covers what happens if you do file->quit from the main menu with a composer open

otherwise, this is a duplicate of that bug.
Comment 3 Milan Crha 2010-06-15 03:27:08 EDT
(In reply to comment #2)
> bug#590373 shows what happens if the main window is closed before the composer
> window
> 
> this bug also covers what happens if you do file->quit from the main menu with
> a composer open

Aha, I would suppose it being the same thing, but after testing I see that using File->Quit and the "x" to close the main application window in Evolution is a very different thing. Thanks for the clarification.

I'm marking this as a duplicate of the older bug and I'm reopening the upstream bug mentioned there with your use case.

*** This bug has been marked as a duplicate of bug 590373 ***

Note You need to log in before you can comment on or make changes to this bug.