This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 590388 - wpa_supplicant-0.7.3 is available
wpa_supplicant-0.7.3 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 06:20 EDT by Upstream Release Monitoring
Modified: 2011-01-11 10:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-11 10:19:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2010-05-09 06:20:17 EDT
Latest upstream release: 0.6.10
Current version in Fedora Rawhide: 0.6.8
URL: http://w1.fi/wpa_supplicant/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 1 acount closed by user 2010-05-09 07:40:44 EDT
2010-01-12 - v0.6.10
	* fixed SHA-256 based key derivation function to match with the
	  standard when using CCMP (for IEEE 802.11r and IEEE 802.11w)
	  (note: this breaks interoperability with previous version) [Bug 307]
	* changed driver_wext to disconnect at init/deinit to clear state
	* added explicit disconnect on 4-way handshake failures
	* added WPS workarounds for known interoperability issues with broken,
	  deployed implementation
	* update IEEE 802.11w implementation to match with the published
	  standard
	* do not send WPS M8 message when learning current AP configuration as
	  an external Registrar
	* added a workaround for race condition between receive EAPOL frames
	  and association events
	* fixed compilation with newer GnuTLS versions
	* fixed PKCS#12 use with OpenSSL 1.0.0

2009-03-23 - v0.6.9
	* driver_ndis: add PAE group address to the multicast address list to
	  fix wired IEEE 802.1X authentication
	* fixed IEEE 802.11r key derivation function to match with the standard
	  (note: this breaks interoperability with previous version) [Bug 303]
Comment 2 Dan Williams 2010-05-12 15:18:50 EDT
It's likely for rawhide that we'll move directly to the 0.7.x series.  I'm happy to backport anything that looks like a bug fix from 0.6.10 though; I did look through git recently and didn't find anything terribly critical in wpa_supplicant itself.

We've already got at least a few of these ("changed driver_wext to disconnect at init/deinit to clear state", "added a workaround for race condition between receive EAPOL frames and association events", "fixed PKCS#12 use with OpenSSL 1.0.0") in our current packages.
Comment 3 Upstream Release Monitoring 2010-05-17 06:46:59 EDT
Latest upstream release: 0.7.2
Current version in Fedora Rawhide: 0.6.8
URL: http://w1.fi/wpa_supplicant/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 4 Upstream Release Monitoring 2010-06-26 06:24:04 EDT
Latest upstream release: 0.6.10
Current version in Fedora Rawhide: 0.6.8
URL: http://w1.fi/releases/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 5 Account closed by user 2010-11-27 10:17:50 EST
0.7.x tree is now STABLE, latest is 0.7.3 http://w1.fi/releases.html
Comment 7 Upstream Release Monitoring 2010-12-01 15:23:21 EST
Latest upstream release: 0.7.3
Current version in Fedora Rawhide: 0.6.8
URL: http://w1.fi/releases/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 8 Dan Williams 2011-01-11 10:19:43 EST
0.7.3 was built for rawhide on 2010-12-15.

Note You need to log in before you can comment on or make changes to this bug.