Bug 590413 - OVIRT35 - [RFE] Admin GUI: Sort by 'IP address' (in VM tab) should not treat the IP address as a string
OVIRT35 - [RFE] Admin GUI: Sort by 'IP address' (in VM tab) should not treat ...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
unspecified
All Windows
low Severity medium
: ---
: 3.5.0
Assigned To: Lior Vernia
network
: EasyFix, FutureFeature, Reopened
Depends On: 893999
Blocks: 1114242 1114244
  Show dependency treegraph
 
Reported: 2010-05-09 09:01 EDT by Yaniv Kaul
Modified: 2016-02-10 14:38 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1114242 1114244 (view as bug list)
Environment:
Last Closed: 2014-10-17 08:31:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 28272 None None None Never

  None (edit)
Description Yaniv Kaul 2010-05-09 09:01:08 EDT
Description of problem:
If I click on the VMs tab on the 'IP address' header, the sort is done as if it was a text field:
10.35.113.9
10.35.113.30
10.35.113.3
10.35.113.16

where one would expect the order to be:
10.35.113.30
10.35.113.16
10.35.113.9
10.35.113.3


Version-Release number of selected component (if applicable):
sm62

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Kaul 2010-05-09 10:06:14 EDT
I thought it was a bug.
And Max reminded me that also the name sort is not done quite correctly. It should be done in 'natural' order (http://www.codinghorror.com/blog/2007/12/sorting-for-humans-natural-sort-order.html)
Comment 2 Itamar Heim 2012-01-05 05:54:21 EST
not sure if this should be fixed at UI level or search sort level
Comment 3 Lior Vernia 2012-12-30 08:13:24 EST
As far as I can see, the IP header is not clickable (anymore?) so the bug is irrelevant (or maybe just obsolete). Yaniv?
Comment 4 Yaniv Kaul 2012-12-30 08:46:31 EST
(In reply to comment #3)
> As far as I can see, the IP header is not clickable (anymore?) so the bug is
> irrelevant (or maybe just obsolete). Yaniv?

There should be a bug that in the move from the old UI to the old one we've lost all sorting per headers :(
Einav?
Comment 5 Einav Cohen 2013-01-10 08:56:49 EST
(In reply to comment #4)
> (In reply to comment #3)
> > As far as I can see, the IP header is not clickable (anymore?) so the bug is
> > irrelevant (or maybe just obsolete). Yaniv?
> 
> There should be a bug that in the move from the old UI to the old one we've
> lost all sorting per headers :(
> Einav?

That's right - when solving bug 893999, need to keep this bug in mind -> putting bug 893999 as a blocker to this one.
Comment 6 Einav Cohen 2013-01-10 09:47:14 EST
(In reply to comment #2)
> not sure if this should be fixed at UI level or search sort level

as long as the UI sort and the backend sort are not "connected" - it should be fixed in both (assuming the search-language allows sorting according to ip-address), in order to prevent inconsistent behavior.

worth considering consolidating the two, maybe in the context of blocking bug 893999.
Comment 7 Sven Kieske 2014-04-25 11:04:00 EDT
I'm not sure this one should be closed yet?
Comment 8 Lior Vernia 2014-04-27 03:05:17 EDT
Well, it's basically fixed. The bug blocking this is about to be fixed, while the backend sorting by IP had been fixed as part of Bug 895468. So whenever the blocker bug is fixed, this could be moved to ON_QA for verification, or alternatively forgotten :)
Comment 9 Lior Vernia 2014-05-28 09:15:57 EDT
Sven, I was actually too quick to respond, you're right and this should be reopened - there's still a little wiring missing for this to work by clicking on the column header.
Comment 10 Sandro Bonazzola 2014-10-17 08:31:59 EDT
oVirt 3.5 has been released and should include the fix for this issue.
Comment 11 David 2015-03-06 06:24:47 EST
Hi, sorry if this is not the place.

But in oVirt 3.5.1.1-1.fc20 when you click in the header "IP Address" the small arrow changes direction, but the rows aren't sorted, and if you try to refresh the webpage or you change to another category and then return to the vms view, there is no information (rows), only 3 square dots in a loop. 

Could possibly it be related to this bug?
Comment 12 Sven Kieske 2015-03-06 07:28:17 EST
@Nir: How did you verify this works?

based on Comment 11 there still seems to be a bug?

Was Liors missing "wiring" from comment 9 fixed?
Comment 13 Lior Vernia 2015-03-08 04:13:58 EDT
No, feature was completely implemented but there's a regression in 3.5, see Bug 1164235 (due to another bug fix...).

Note You need to log in before you can comment on or make changes to this bug.