Bug 590478 - SELinux is preventing /usr/bin/python "link" access on vmlinuz.
Summary: SELinux is preventing /usr/bin/python "link" access on vmlinuz.
Keywords:
Status: CLOSED DUPLICATE of bug 590477
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:c968f8b21cf...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-09 18:34 UTC by Subhendu Ghosh
Modified: 2010-05-10 14:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-10 14:22:28 UTC
Type: ---


Attachments (Terms of Use)

Description Subhendu Ghosh 2010-05-09 18:34:26 UTC
Summary:

SELinux is preventing /usr/bin/python "link" access on vmlinuz.

Detailed Description:

[cobblerd has a permissive type (cobblerd_t). This access was not denied.]

SELinux denied access requested by cobblerd. It is not expected that this access
is required by cobblerd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:cobblerd_t:s0
Target Context                system_u:object_r:httpd_sys_content_t:s0
Target Objects                vmlinuz [ file ]
Source                        cobblerd
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.2-4.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-114.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.x86_64
                              #1 SMP Mon Apr 5 19:59:38 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sun 09 May 2010 01:20:05 PM EDT
Last Seen                     Sun 09 May 2010 01:20:05 PM EDT
Local ID                      e8ff5316-b63a-4db0-894e-34de17732fe7
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273425605.767:14509): avc:  denied  { link } for  pid=11189 comm="cobblerd" name="vmlinuz" dev=dm-3 ino=8655204 scontext=system_u:system_r:cobblerd_t:s0 tcontext=system_u:object_r:httpd_sys_content_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1273425605.767:14509): arch=c000003e syscall=86 success=yes exit=0 a0=7f00c400cc60 a1=7f00c4008580 a2=3db7fb0e40 a3=2d617465422d364c items=0 ppid=1 pid=11189 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2326 comm="cobblerd" exe="/usr/bin/python" subj=system_u:system_r:cobblerd_t:s0 key=(null)



Hash String generated from  catchall,cobblerd,cobblerd_t,httpd_sys_content_t,file,link
audit2allow suggests:

#============= cobblerd_t ==============
allow cobblerd_t httpd_sys_content_t:file link;

Comment 1 Daniel Walsh 2010-05-10 14:22:28 UTC

*** This bug has been marked as a duplicate of bug 590477 ***


Note You need to log in before you can comment on or make changes to this bug.