Bug 590477 - SELinux is preventing /usr/bin/rsync "create" access on repodata.
SELinux is preventing /usr/bin/rsync "create" access on repodata.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:481619341d9...
:
: 590478 590479 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 14:33 EDT by Subhendu Ghosh
Modified: 2010-07-08 20:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 20:22:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2010-05-09 14:33:37 EDT
Summary:

SELinux is preventing /usr/bin/rsync "create" access on repodata.

Detailed Description:

[rsync has a permissive type (cobblerd_t). This access was not denied.]

SELinux denied access requested by rsync. It is not expected that this access is
required by rsync and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:cobblerd_t:s0
Target Context                system_u:object_r:httpd_sys_content_t:s0
Target Objects                repodata [ dir ]
Source                        rsync
Source Path                   /usr/bin/rsync
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           rsync-3.0.7-3.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-114.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.x86_64
                              #1 SMP Mon Apr 5 19:59:38 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sun 09 May 2010 01:19:01 PM EDT
Last Seen                     Sun 09 May 2010 01:19:01 PM EDT
Local ID                      76a043e8-6339-409d-aa94-52e92e4b32aa
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273425541.819:14504): avc:  denied  { create } for  pid=11194 comm="rsync" name="repodata" scontext=system_u:system_r:cobblerd_t:s0 tcontext=system_u:object_r:httpd_sys_content_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1273425541.819:14504): arch=c000003e syscall=83 success=yes exit=0 a0=7fff31cdcfa0 a1=140 a2=e a3=0 items=0 ppid=11193 pid=11194 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2326 comm="rsync" exe="/usr/bin/rsync" subj=system_u:system_r:cobblerd_t:s0 key=(null)



Hash String generated from  catchall,rsync,cobblerd_t,httpd_sys_content_t,dir,create
audit2allow suggests:

#============= cobblerd_t ==============
allow cobblerd_t httpd_sys_content_t:dir create;
Comment 1 Daniel Walsh 2010-05-10 10:22:28 EDT
*** Bug 590478 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2010-05-10 10:27:11 EDT
Where is the repo located.
Comment 3 Miroslav Grepl 2010-05-10 11:41:46 EDT
*** Bug 590479 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Walsh 2010-05-10 13:12:50 EDT
Miroslav, we added  httpd_cobbler_content_rw_t but it is not assigned to any files?
Comment 5 Subhendu Ghosh 2010-05-10 18:43:00 EDT
I was doing a cobbler import off a loopback mounted iso
Comment 6 Miroslav Grepl 2010-05-11 08:01:19 EDT
(In reply to comment #4)
> Miroslav, we added  httpd_cobbler_content_rw_t but it is not assigned to any
> files?    

Dan,
I guess this type was originally used for /var/www/cobbler directory. Now we have only this label

/var/www/cobbler/images(/.*)?   gen_context(system_u:object_r:public_content_rw_t, s0)


I think it was Dominic's intent. So we should add the same label for 

/var/www/cobbler/ks_mirror(/.*)? 
gen_context(system_u:object_r:public_content_rw_t, s0)

/var/www/cobbler/links(/.*)? 
gen_context(system_u:object_r:public_content_rw_t, s0)

Will fix this bug.
Comment 7 Daniel Walsh 2010-05-11 10:30:58 EDT
Fixed in selinux-policy-3.7.19-15.fc13.noarch

Note You need to log in before you can comment on or make changes to this bug.