Bug 590479 - SELinux is preventing /usr/bin/python "rename" access on repodata.
SELinux is preventing /usr/bin/python "rename" access on repodata.
Status: CLOSED DUPLICATE of bug 590477
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:17b4fc33682...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-09 14:35 EDT by Subhendu Ghosh
Modified: 2010-05-10 11:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 11:41:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2010-05-09 14:35:12 EDT
Summary:

SELinux is preventing /usr/bin/python "rename" access on repodata.

Detailed Description:

[genpkgmetadata. has a permissive type (cobblerd_t). This access was not
denied.]

SELinux denied access requested by genpkgmetadata.. It is not expected that this
access is required by genpkgmetadata. and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:cobblerd_t:s0
Target Context                system_u:object_r:httpd_sys_content_t:s0
Target Objects                repodata [ dir ]
Source                        genpkgmetadata.
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.2-4.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-114.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.11-99.fc12.x86_64
                              #1 SMP Mon Apr 5 19:59:38 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sun 09 May 2010 01:22:47 PM EDT
Last Seen                     Sun 09 May 2010 01:22:47 PM EDT
Local ID                      e4387600-6c35-4305-b890-2434b81be89b
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1273425767.665:14513): avc:  denied  { rename } for  pid=11255 comm="genpkgmetadata." name="repodata" dev=dm-3 ino=8651975 scontext=system_u:system_r:cobblerd_t:s0 tcontext=system_u:object_r:httpd_sys_content_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1273425767.665:14513): arch=c000003e syscall=82 success=yes exit=0 a0=160b3a0 a1=1660540 a2=3db7fb0e40 a3=7465422d364c4548 items=0 ppid=8706 pid=11255 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2326 comm="genpkgmetadata." exe="/usr/bin/python" subj=system_u:system_r:cobblerd_t:s0 key=(null)



Hash String generated from  catchall,genpkgmetadata.,cobblerd_t,httpd_sys_content_t,dir,rename
audit2allow suggests:

#============= cobblerd_t ==============
allow cobblerd_t httpd_sys_content_t:dir rename;
Comment 1 Miroslav Grepl 2010-05-10 11:41:46 EDT

*** This bug has been marked as a duplicate of bug 590477 ***

Note You need to log in before you can comment on or make changes to this bug.