Bug 590697 - Add support for a fence agent connect directly to libvirt ESX or vSphere/VirtualCenter server
Summary: Add support for a fence agent connect directly to libvirt ESX or vSphere/Virt...
Keywords:
Status: CLOSED DUPLICATE of bug 634567
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman
Version: 5.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 610811
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 14:00 UTC by Perry Myers
Modified: 2011-03-16 22:33 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 590696
Environment:
Last Closed: 2010-09-23 19:06:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Perry Myers 2010-05-10 14:00:31 UTC
+++ This bug was initially created as a clone of Bug #590696 +++

Description of problem:
fence_vmware uses a proprietary perl API that is not in RHEL.  But the libvirt client in RHEL6 supports URIs to connect to both ESX and VirtualCenter/vSphere mgmt servers.

We should be able to point fence_virt on a virtual cluster node to point to the vSphere/VirtualCenter server for all other guests so that it can just ask the mgmt server to do the fencing for it.

This does not affect fence_virtd at all since in ESX deployments we have no host access so there will be no fence_virtd running.

This may also require backporting fence_virt or a similar agent to RHEL5 to support the RHEL5 use case.

Comment 5 Perry Myers 2010-09-23 19:06:41 UTC

*** This bug has been marked as a duplicate of bug 634567 ***


Note You need to log in before you can comment on or make changes to this bug.