This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 634567 - Rework fence_vmware fence agent to use SOAP API to connect to Virtual Center instead of VMware Perl API
Rework fence_vmware fence agent to use SOAP API to connect to Virtual Center ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.5
All Linux
high Severity high
: rc
: ---
Assigned To: Marek Grac
Cluster QE
: ReleaseNotes
: 590697 (view as bug list)
Depends On: 668522 681834
Blocks: 688385 688387 688389 688390 693433
  Show dependency treegraph
 
Reported: 2010-09-16 07:55 EDT by Perry Myers
Modified: 2011-07-21 03:15 EDT (History)
7 users (show)

See Also:
Fixed In Version: cman-2.0.115-84.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 624673
: 693433 (view as bug list)
Environment:
Last Closed: 2011-07-21 03:15:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2010-09-16 07:55:23 EDT
+++ This bug was initially created as a clone of Bug #624673 +++

Description of problem:
Existing fence_vmware uses 3rd party RPM dependency from VMware (VMware Perl API).  libvirt VMware/ESX driver implemented a SOAP method to connect to Virtual Center.

libvirt usage is fairly different than what we want for a general fence agent, so it's been recommended by libvirt team that we lift their SOAP code (just the parts of it that we need for the fence agent) and use it to rework the fence_vmware agent.

--- Additional comment from rohara@redhat.com on 2010-08-30 14:13:27 EDT ---

Doing this will allow us to remove fence_vmware_helper.pl and fence_vware can be exclusively Python code. This will likely create a dependency on a SOAP module to be pulled into Pyton, such as SOAPy.

The vmware web site has a "VMware Infrastructure SDK Programming Guide" that seems helpful, too. Basic power on/off operations are PowerOnVM_Task and PowerOffVM_Task. Also look at libvirt, which uses a C API but has some python code to generate the SOAP code. This is more than we need for fence_vmware, but might be a handy reference.

--- Additional comment from pmyers@redhat.com on 2010-09-16 07:53:33 EDT ---

*** Bug 486207 has been marked as a duplicate of this bug. ***
Comment 1 Perry Myers 2010-09-23 15:06:41 EDT
*** Bug 590697 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2011-01-11 15:24:06 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-01-11 17:20:50 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 12 errata-xmlrpc 2011-07-21 03:15:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1001.html

Note You need to log in before you can comment on or make changes to this bug.