Bug 591169 - srptools/rdma seems to be missing the SRP HA init script present in OFED
srptools/rdma seems to be missing the SRP HA init script present in OFED
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: srptools (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Doug Ledford
Network QE
:
: 602948 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 11:26 EDT by Justin Clift
Modified: 2011-05-19 10:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:23:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0755 normal SHIPPED_LIVE srptools bug fix and enhancement update 2011-05-18 14:08:54 EDT

  None (edit)
Description Justin Clift 2010-05-11 11:26:57 EDT
Description of problem:

Although srptools is present in RHEL 6 beta, and includes srp_daemon, srp_daemon.sh, and run_srp_daemon, it appears to be missing the init.d scripting to start this automatically at system boot.


Version-Release number of selected component (if applicable):

srptools-0.0.4-7.el6.x86_64


How reproducible:

Every time.


Steps to Reproduce:
1. Install the RHEL 6 Infiniband packages (ie srptools, rdma, various others)
2. Check in /etc/rdma, /etc/ofed, and /etc/init.d/* for scripting to automatically start the SRP HA daemon at boot time.
3.
  
Actual results:

It doesn't seem to be present.


Expected results:

There should be a mechanism to automatically start the SRP daemon at boot time, possibly as part of the "rdma" init script (similar to how OFED works).

Additional info:

OFED does this via the /etc/init.d/openibd script, making use of an "SRPHA_ENABLE" variable (yes/no) in /etc/infiniband/openib.conf.  Maybe a similar approach would be useful here, possibly inside the rdma init scripts?
Comment 2 RHEL Product and Program Management 2010-05-11 12:44:50 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 RHEL Product and Program Management 2010-07-15 10:52:13 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Doug Ledford 2010-08-02 10:20:21 EDT
*** Bug 602948 has been marked as a duplicate of this bug. ***
Comment 5 Denise Dumas 2010-09-17 14:01:35 EDT
Per Doug, moving to 6.1
Comment 7 Doug Ledford 2011-02-03 22:56:43 EST
FWIW, hooking this into the rdma startup script is the wrong place to do it.  A script from another package should never be starting binaries from this package.  A new script was created, srpd, and that service will now bring up the srp daemon at a point in the boot up sequence that is appropriate for a network block device.  Please test this in your environment, I may need to adjust the startup sequence to work with devices that are automounted from /etc/fstab.
Comment 10 errata-xmlrpc 2011-05-19 10:23:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0755.html

Note You need to log in before you can comment on or make changes to this bug.